Should not display the notification bar if user completed all the tours

RESOLVED DUPLICATE of bug 1357641

Status

()

Firefox
General
P1
normal
RESOLVED DUPLICATE of bug 1357641
a year ago
a year ago

People

(Reporter: Fischer, Assigned: Fischer)

Tracking

unspecified
Firefox 57
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

a year ago
Should not display the notification for the completed tour
(Assignee)

Updated

a year ago
Whiteboard: [photon-onboarding]

Comment 1

a year ago
What we want is that the user can complete all of the tour steps (has a checkmark for all six items) and the Fox icon will remain on the new tab page so that they can revisit the tour when they want. If the user then checks the box to remove the tips menu, we should remove the fox icon from the new tab page. In other words, the tour is only "complete" when the user marks it as complete.
(Assignee)

Updated

a year ago
Summary: Should not display the notification for the completed tour → Should not display the notification bar for the completed tour
(Assignee)

Comment 2

a year ago
(In reply to Verdi [:verdi] from comment #1)
> What we want is that the user can complete all of the tour steps (has a
> checkmark for all six items) and the Fox icon will remain on the new tab
> page so that they can revisit the tour when they want. If the user then
> checks the box to remove the tips menu, we should remove the fox icon from
> the new tab page. In other words, the tour is only "complete" when the user
> marks it as complete.
Hi Verdi,
What this bug intends to do is not to display the *notification bar* (not about fox icon) if user completed all 6 tours.
It might looks like a bug/strange behaviour that the notification bar still appear to ask user to try out tours even though user did all the tours.
Does the descriptions above match what we want to do in the specs?
Thank you
Flags: needinfo?(mverdi)

Comment 3

a year ago
Thanks Fischer - that makes sense.
Flags: needinfo?(mverdi)
(Assignee)

Updated

a year ago
Summary: Should not display the notification bar for the completed tour → Should not display the notification bar if user completed all the tours

Updated

a year ago
Priority: -- → P2
Target Milestone: --- → Firefox 57

Updated

a year ago
Flags: qe-verify+
QA Contact: jwilliams
Do you think we need move this to P1 since we'll do notification in v56?
Flags: needinfo?(fliu)
(Assignee)

Comment 5

a year ago
(In reply to Fred Lin [:gasolin] from comment #4)
> Do you think we need move this to P1 since we'll do notification in v56?
Yes, I think so as well. And plan to fix this with Bug 1357641 together.
Flags: needinfo?(fliu)
Priority: P2 → P1
(Assignee)

Updated

a year ago
Assignee: nobody → fliu
Status: NEW → ASSIGNED
(Assignee)

Comment 6

a year ago
This bug will be done with Bug 1357641 together so duplicate it
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1357641
remove whiteboard tag due to its DUPLICATE
Whiteboard: [photon-onboarding]
You need to log in before you can comment on or make changes to this bug.