Reducing the width of the window while the last tab is selected causes the tabstrip to animate

VERIFIED FIXED in Firefox 55

Status

()

Firefox
Tabbed Browser
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: florian, Assigned: florian)

Tracking

unspecified
Firefox 55
Points:
---

Firefox Tracking Flags

(firefox55 verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

a year ago
This feels slow, I'm not sure there's a reason for it or if it was an accident.
(Assignee)

Comment 1

a year ago
Created attachment 8858793 [details] [diff] [review]
Trivial patch

This feels too easy, hopeful you know if I'm missing something :-).
Attachment #8858793 - Flags: review?(dao+bmo)
(Assignee)

Updated

a year ago
Assignee: nobody → florian
Status: NEW → ASSIGNED
Attachment #8858793 - Flags: review?(dao+bmo) → review+

Comment 2

a year ago
Pushed by florian@queze.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1735bad11778
Reducing the width of the window while the last tab is selected shouldn't causes the tabstrip to animate, r=dao.

Comment 3

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1735bad11778
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55

Comment 4

a year ago
[bugday-20170419]

status-ff55 : VERIFIED & NOT FIXED.

The issue can be still reproduced on Firefox latest Nightly [BuildID : 20170419030223 , 55.0a1(2017-04-19)(32 bit)]. 
Tests were performed under Windows 10 X 64.

Please refer the GIF attached.

Comment 5

a year ago
Created attachment 8859579 [details]
2017-04-19_18h49_00.gif
(Assignee)

Comment 6

a year ago
(In reply to Madhuri from comment #4)
> [bugday-20170419]
> 
> status-ff55 : VERIFIED & NOT FIXED.
> 
> The issue can be still reproduced on Firefox latest Nightly [BuildID :
> 20170419030223 , 55.0a1(2017-04-19)(32 bit)]. 
> Tests were performed under Windows 10 X 64.
> 
> Please refer the GIF attached.

This gif shows overflow, and scrolling through it. Animating is intended there. This bug is about resizing the window: you grab the right border of the window and then slowly drag it to the left to reduce the window size. The selected tab should stay visible.
Attachment #8859579 - Attachment is obsolete: true

Comment 7

a year ago
(In reply to Florian Quèze [:florian] [:flo] from comment #6)
> (In reply to Madhuri from comment #4)
> > [bugday-20170419]
> > 
> > status-ff55 : VERIFIED & NOT FIXED.
> > 
> > The issue can be still reproduced on Firefox latest Nightly [BuildID :
> > 20170419030223 , 55.0a1(2017-04-19)(32 bit)]. 
> > Tests were performed under Windows 10 X 64.
> > 
> > Please refer the GIF attached.
> 
> This gif shows overflow, and scrolling through it. Animating is intended
> there. This bug is about resizing the window: you grab the right border of
> the window and then slowly drag it to the left to reduce the window size.
> The selected tab should stay visible.

Got your point now. I had tested it through different STR.

status-ff55 : VERIFIED & FIXED.

The issue is no longer reproducible on Firefox latest Nightly [BuildID : 20170419030223 , 55.0a1(2017-04-19)(32 bit)]. 
Tests were performed under Windows 10 X 64.
Status: RESOLVED → VERIFIED
status-firefox55: fixed → verified
You need to log in before you can comment on or make changes to this bug.