Closed Bug 1357194 Opened 4 years ago Closed 4 years ago

AccessibleHandler CLSID not working as intended

Categories

(Core :: Disability Access APIs, enhancement)

Unspecified
Windows
enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: aklotz, Assigned: aklotz)

Details

Attachments

(1 file)

Looks like the problem was that I had a misunderstanding about how we distinguish local builds from Nightly builds.

I also want to add a set of GUIDs to make beta and release distinct.
Comment on attachment 8858917 [details]
Bug 1357194: Use MOZ_UPDATE_CHANNEL to distinguish between local/nightly and beta/release builds for AccessibleHandler CLSIDs

https://reviewboard.mozilla.org/r/130908/#review133502
Attachment #8858917 - Flags: review?(mhowell) → review+
Comment on attachment 8858917 [details]
Bug 1357194: Use MOZ_UPDATE_CHANNEL to distinguish between local/nightly and beta/release builds for AccessibleHandler CLSIDs

https://reviewboard.mozilla.org/r/130908/#review133884

::: accessible/ipc/win/handler/moz.build:53
(Diff revision 1)
>  # but we still want to be able to delegate some work to the generated code,
>  # we add the prefix "Proxy" to all of the generated counterparts.
>  DEFINES['ENTRY_PREFIX'] = 'Proxy'
>  DEFINES['REGISTER_PROXY_DLL'] = True
>  
> +if CONFIG['MOZ_UPDATE_CHANNEL'] == 'default':

This block should probably have a comment, since it's not clear from just looking at the moz.build file why you would only set a value for 'default' and 'beta'.
Attachment #8858917 - Flags: review?(mshal) → review+
Pushed by aklotz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9434a31807d5
Use MOZ_UPDATE_CHANNEL to distinguish between local/nightly and beta/release builds for AccessibleHandler CLSIDs; r=mhowell,mshal
https://hg.mozilla.org/mozilla-central/rev/9434a31807d5
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.