Reply to fails to add addresses - caused by add-on Contact Photo

RESOLVED INVALID

Status

Thunderbird
Untriaged
RESOLVED INVALID
2 months ago
6 days ago

People

(Reporter: barrys, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [add-on: ContactPhoto])

(Reporter)

Description

2 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36

Steps to reproduce:

I am trying to reply to emails. When I hit the reply button, I get a compose window but no "to" addresses populated. This happens for all incoming email.Reply all fails the same way.


Actual results:

No addresses


Expected results:

The to: field(s) should be populated

Comment 1

2 months ago
Please try with all add-ons disabled (see Help menu). This is most likely caused by an incompatible add-on, perhaps "MoreFunctionsForAddressBook".
(Reporter)

Comment 2

2 months ago
THanks for the quick response.

If I boot in 'safe' mode it starts working again.

I have the following add-ons installed:

gContactSync
Google Tasks Sync
Lightning
Master Password +
Providor for Google Cal
Display Contact Photo
SunCult

I have currently disabled both the Contact Photo and SunCult and I have it working.

Thanks, the help is greatly appreciated.

Comment 3

2 months ago
Thanks for letting us know. I think it's caused by Contact Photo, I've seen reports to that effect before.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → INVALID
Whiteboard: [add-on: ContactPhoto]

Updated

2 months ago
Duplicate of this bug: 1362352

Comment 5

2 months ago
thx for referring to the other ticket. It was caused by Contact Photo in my case too.

Updated

a month ago
Duplicate of this bug: 1355034

Updated

a month ago
Duplicate of this bug: 1365888

Updated

a month ago
Duplicate of this bug: 1366436

Comment 9

a month ago
The problem was reported in reviews at AMO
https://addons.mozilla.org/en-US/thunderbird/addon/display-contact-photo/
but the add-on author hasn't reacted. Last update in 2015. I've contacted the author at displaycontactphoto@gmail.com.

Comment 10

a month ago
I just tried disabling Contact Photo and restarting Thunderbird.
Problem still occurs.

Comment 11

a month ago
Previous comment withdrawn. 
Appears to be Contact Photo's problem.
I apologize for the noise.

Comment 12

a month ago
You got me worried for a minute ;-(

Updated

a month ago
Summary: Reply to fails to add addresses → Reply to fails to add addresses - caused by add-on Contact Photo

Updated

a month ago
Duplicate of this bug: 1366997

Comment 14

a month ago
Okay, I can confirm that the problem comes with "Contact Photo".
But that is not all: Concerning, that with older versions of Thunderbird this add-on works fine, there must be a change in Thunderbird that caused the now arising error.
As long as the author of the add-on doesn't react to requests for an update, the question is: Which changes are made to Thunderbird that causes the incompatibility and are these changes necessary?
I'll miss "Contact Photo", because it is a nice and useful add-on, if there will be no solution for this problem.

Comment 15

a month ago
(In reply to CWH from comment #14)
> As long as the author of the add-on doesn't react to requests for an update,
> the question is: Which changes are made to Thunderbird that causes the
> incompatibility and are these changes necessary?
We make hundreds of changes, some of them forced onto us by the ever-changing Mozilla platform. They are all necessary.

Add-on authors have plenty of time to test their add-ons with alpha or beta software of Thunderbird. There is no excuse for not adapting add-ons to the latest changes.

Say you go to Karstadt (German department store) with a 100 DM bill (former German currency). You think they will accept that?

Comment 16

a month ago
> We make hundreds of changes, some of them forced onto us by the ever-changing Mozilla platform. They are all necessary.
Okay, understood.

> Add-on authors have plenty of time to test their add-ons with alpha or beta software of Thunderbird. 
That is an unproven predication. You don't know how much time the authors are able to spend on their work.

> There is no excuse for not adapting add-ons to the latest changes.
Who ever knows what happened to the author or what his reasons are not to update the add-on since two years.

> Say you go to Karstadt (German department store) with a 100 DM bill (former German currency). You think they will accept that?
This comparison does not fit properly. If you still have DM bills, you can change them at the bank into EUR (I'm sure you know) - or you can store them safely and hope they become a historical relict and get more valuable.
To the question: The risk is very high, that Karstadt will not accept DM instead of EUR - probably depending on the clerk at the cash desk, who is taking the bill (he might be careless).


As a conclusion to this bug, it seems I have to live without the add-on.
Probably I find something similar. 

Have a nice holiday (Christi Himmelfahrt / Vatertag)!

Comment 17

a month ago
Lot of discussion. Hope I shed light rather than heat. Maybe. Hey, it could happen ...

The rate of change of TB seems excessively high. Every update results in at least one add-on being declared "not compatible". Most add-on developers (from what I can tell, anyway) are like me: volunteers who contribute spare time as they can find it to develop useful add-ons to make TB usable.

It would be wonderful if we could all completely and thoroughly retest our add-ons on every platform every time TB/Moz decides to update TB. But frankly, we can't. In my case, I "adopted" an "orphan" add-on that was last published to be compatible with TB 1.5 (yes, one dot five). I have attempted to keep it working, but am losing the battle. It crashes on Ubuntu, but not on Windows. I don't use Ubuntu. So I can't test there. The ability to save word substitutions stopped working many major revisions ago. I assume Moz/TB decided to change something about local file storage, and I have no idea how to fix it. I'm guessing that may developers are in the same boat - the leaking sinking boat.

I liked the Contact Photo add-on, but it isn't critical to me. I need my own add-on (mmsAutoCorrect) because of my poor typing skills (DOuble CApitals, which my add-on fixes). Someday I might learn enough to fix the word substitution feature. Maybe. And then hope that Moz/TB doesn't change drastically again, which it will.

So,  USERS: please have patience with us volunteers who create free add-ons for you.
MOZILLA/TB: please have mercy on us volunteers who create free add-ons for your users.

Mike [;-}>

Updated

a month ago
Duplicate of this bug: 1367640

Updated

a month ago
Duplicate of this bug: 1367788

Updated

21 days ago
Duplicate of this bug: 1369998

Updated

16 days ago
Duplicate of this bug: 1371033

Updated

6 days ago
Duplicate of this bug: 1374111
You need to log in before you can comment on or make changes to this bug.