Open Bug 1357305 Opened 5 years ago Updated 2 years ago

Huge Website / bad website is making firefox unusable

Categories

(Core :: Layout, defect)

52 Branch
defect
Not set
normal

Tracking

()

REOPENED

People

(Reporter: johannes.feigl, Unassigned, NeedInfo)

Details

(Keywords: csectype-dos)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170323105023

Steps to reproduce:

hello,

i am developing some php application.

sometimes if there is a problem with the application it creating a huge result/website.

then firefox cannot handle that and will consume all memory until you close with task manger


Actual results:

just try to create e.g. a php script with

<?php do { echo "HELLO WORLD<br>\n"; } while(1); ?>

then open with firefox,
you will get a lot of hello world, but soon firefox is unusable.


Expected results:

maybe a message like firefix is already when i javascript is consuming a lot cpu/memory

stop website: yes/no ?
Component: Untriaged → Memory Allocator
Keywords: csectype-dos, dupeme
Product: Firefox → Core

Moving this bug report about memory usage (which is not related to the memory allocator) to Untriaged.

Component: Memory Allocator → Untriaged
Product: Core → Firefox
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Keywords: dupeme
Resolution: --- → DUPLICATE
Duplicate of bug: 1164189

Why was this duped? Seems like comment 0 definitely creates more than one line, it's just an infinite page.

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Hi Johannes Feigl,
Try updating the Firefox version to the latest and try again to see if the issue persist. If the issue persist, please try to reproduce it on Nightly, you can download it from here https://www.mozilla.org/en-US/firefox/nightly/all/
Lastly, could you provide a test case for this please?

Thanks!

Flags: needinfo?(johannes.feigl)

hello Luciana,

well i don't see any change at the moment with the nightly version.

i use this php script for test:

for ($i = 0; $i <1000; $i++) {
usleep (100000);
for ($j = 0; $j <100; $j++) {
echo "test $i $j <br>";
}
}

of course this is not a site which makes since, but sometimes i get a very big table, which is cousing troubles...

mfg johannes

Flags: needinfo?(johannes.feigl)

Hi Johannes Feigl ,

Thanks for your feedback, will set the product (Core) and component (layout) for this issue. There's a new Nightly version to download if you would like to try on the new one, here is the link https://www.mozilla.org/en-US/firefox/nightly/all/
Also, would you please share a link with an example test case so is quicker and easier to replicate this issue?

Thanks!

Component: Untriaged → Layout
Flags: needinfo?(johannes.feigl)
Product: Firefox → Core
You need to log in before you can comment on or make changes to this bug.