Closed Bug 1357354 Opened 6 years ago Closed 6 years ago

[developper edition] google font not working | DFLT script doesn't satisfy the spec

Categories

(Core :: Graphics: Text, defect)

54 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1331797

People

(Reporter: stefan.kruger, Unassigned)

Details

Attachments

(1 file)

Attached image console view
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170417004005

Steps to reproduce:

Used roboto google font


Actual results:

css error in console : 

downloadable font: Layout: DFLT script doesn't satisfy the spec. DefaultLangSys is NULL (font-family: "Roboto Condensed" style:normal weight:normal stretch:normal src index:2) source: https://fonts.gstatic.com/s/robotocondensed/v14/Zd2E9abXLFGSr9G3YK2MsDAdhzWOYhqHvOZMRGaEyPo.woff2


Expected results:

no error and usage of font OK
I think this is the same issue as https://github.com/webcompat/web-bugs/issues/4742
Component: Untriaged → Graphics: Text
Product: Firefox → Core
Thanks for your answer, it indeed looks like a similar issue. 
Do i close this one as it doesn't looks like a bug but a stricter application of rules ?
Also occurring for me.

Firefox Developer Edition 54.0a2 (2017-04-17) (64-bit)
Running on Ubuntu 16.04
ni? Jonathan to have a look for this bug.
Flags: needinfo?(jfkthame)
See bug 1331797. This is a fault in the fonts being served by the Google site.

You can work around it by setting gfx.downloadable_fonts.otl_validation to false in about:config.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(jfkthame)
Resolution: --- → DUPLICATE
Thank you for your answer
You need to log in before you can comment on or make changes to this bug.