Closed Bug 1357406 Opened 5 years ago Closed 5 years ago

Using shortcut keys like ' or / in input fields with the new RDM opens the Find Toolbar instead of writing the characters

Categories

(DevTools :: Responsive Design Mode, defect)

52 Branch
defect
Not set
normal

Tracking

(firefox55 affected)

RESOLVED DUPLICATE of bug 1317323
Tracking Status
firefox55 --- affected

People

(Reporter: cappelli.mauro, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36

Steps to reproduce:

1) open any page containing a textual input field (eg: www.google.com)
2) click the input field so it has the browser focus
3) activate firefox flexible visualization (ctrl+shift+M)
4) write few alphabetical characters
5) press ' (apostrophe) or / (slash)


Actual results:

Firefox activates the quicksearch


Expected results:

Firefox should have wrote ' (apostrophe) or / (slash) into the input field
Is it Firefox 52?
Flags: needinfo?(cappelli.mauro)
(In reply to Alice0775 White from comment #1)
> Is it Firefox 52?

Yes.
The bug exists in both my:

* firefox 52.0.2
* firefox developer edition 54.0a2
Flags: needinfo?(cappelli.mauro)
It appears only with the new RDM when e10s is turned on.
Component: Untriaged → Developer Tools: Responsive Design Mode
Summary: shortcuts usage in input fields with flexible visualiztion → Using shortcut keys like ' or / in input fields with the new RDM opens the Find Toolbar instead of writing the characters
NB: flexible visualization is called Responsive Design.
(In reply to Loic from comment #4)
> NB: flexible visualization is called Responsive Design.

Thank you. Sorry for the wrong labels, mine are both localized Firefoxes and tooltips translation is a bit different than exact translation.
Blocks: 1296498
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Keywords: multiprocess
Thanks for the report!

I don't think there's a useful meta bug for new RDM anymore since it has now shipped to all channels.

Sounds like this is the same as bug 1317323.  If it's a different issue, please reopen!
No longer blocks: 1296498
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1317323
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.