Thunderbird needs a simpler UI mode

UNCONFIRMED
Unassigned

Status

--
enhancement
UNCONFIRMED
2 years ago
2 years ago

People

(Reporter: kdague2006, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170323110425

Steps to reproduce:

I install Thunderbird for all of my clients who need an email client.  Many of them are older, mostly coming from Outlook Express, currently.


Actual results:

Thunderbird is just too complicated.  One recent customer with early-stage dementia simply cannot figure it out.


Expected results:

There should be a "simple mode" with all the buttons right at the top instead of moving around depending how you open the email (preview or tab), no tabs (my older clients simply don't seem to be able to grasp the concept of tabs) and a single unified address book with no options whatsoever so that no matter what you do clicking "To:" brings up all the addresses.  Nothing should move around, appear or disappear.  Instead buttons should get "grayed out" when they don't apply.  It should have a single row of buttons in the toolbar, which never change or move, and if there are buttons in an opened email it should be the same, familiar toolbar.  Double clicking an email should open a new window rather than a tab.  It would also be nice if the settings were more straight-forward like they are in other email clients.  There are, I think, 4 sections in outlook Express, laid out logically.  Open Thunderbird settings and incoming and outgoing server settings are on opposite ends of a massive list of sections.  I understand the potential need to have different server, username and password settings for incoming and outgoing, but really, how often does someone need that?  1 in 10,000 users?  1 in 100,000?  A simpler interface by default simply makes more sense, at least for the settings section.
I remember seeing a similar bug which requested a stable (non-alterable) UI for old or disabled users, but I can't seem to find that now.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1019652
On second thought, this isn't quite the same as bug 1019654
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
See Also: → bug 1019652

Updated

2 years ago
Summary: Thunderbird needs a simple mode → Thunderbird needs a simpler UI mode
You need to log in before you can comment on or make changes to this bug.