crash when removing display from dualhead setup with mozilla running [@nsScreenMac::GetPixelDepth]

RESOLVED WORKSFORME

Status

()

Core
XUL
--
critical
RESOLVED WORKSFORME
17 years ago
7 years ago

People

(Reporter: Mike Akers, Unassigned)

Tracking

(Blocks: 1 bug, {crash})

Trunk
Future
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.9+)
Gecko/20020326
BuildID:    2002032608

I have a TiBook which can do a mulitimoitor display when hooked up to an
external monitor. If im running mozilla in dualhead, and then I remove the
external monitor, mozilla crashes every time. Interestingly, mozilla doesnt
crash if I enable mirroring instead of removing the display.

Reproducible: Always
Steps to Reproduce:
1. Find a TiBook and a spare monitor (dont know if this will also work with
dualhead desktops), get running in dualhead mode
2. start mozilla
3. put the mac to sleep
4. disconnect the external display
5. wake up the mac

Actual Results:  mozilla crashes

Expected Results:  mozilla shouldn't have crashed.

also works if you disconnect the external monitor and click the "Detect
displays" button in the displays section of system preferences instead of steps 3-5

this bug is not unique to this build, I've seen this bug for at least a couple
of months but never reported it :)

if someone can tell me how to get a stacktrace of this crash in OSX I can post it.

Updated

17 years ago
Keywords: crash, stackwanted
(Reporter)

Comment 1

17 years ago
I figured out how to get a stacktrace of the crash, so here it is. Removing
stackwanted from keywords.

This is from build 2002040903

Date/Time:  2002-04-11 15:17:17 -0400
OS Version: 10.1.3 (Build 5Q110)
Host:       makers1.fao.ny.jpmorgan.com

Command:    Mozilla
PID:        454

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000015

Thread 0 Crashed:
 #0   0x0232395c in nsScreenMac::GetPixelDepth(int *)
 #1   0x41700000 in 0x41700000
 #2   0x02316b38 in nsRenderingContextMac::CreateDrawingSurface(nsRect *,
unsigned int, void *&)
 #3   0x0232f0b8 in AllocateBackbuffer__22nsRenderingContextImplFRC6nsRectRC6nsRec
 #4   0x0232ef64 in nsRenderingContextImpl::GetBackbuffer(nsRect const &, nsRect
const &, void *&)
 #5   0x02df9088 in 0x2df9088
 #6   0x02dfc59c in 0x2dfc59c
 #7   0x02df2b78 in HandleEvent(nsGUIEvent *)
 #8   0x020f09b0 in nsWindow::DispatchEvent(nsGUIEvent *, nsEventStatus &)
 #9   0x020f0b10 in nsWindow::DispatchWindowEvent(nsGUIEvent &, nsEventStatus &)
 #10  0x020f031c in nsWindow::UpdateWidget(nsRect &, nsIRenderingContext *)
 #11  0x020ef800 in nsWindow::PaintUpdateRectProc(unsigned short,
OpaqueRgnHandle *, Rect const *, void *)
 #12  0x020efe38 in nsWindow::HandleUpdateEvent(OpaqueRgnHandle *)
 #13  0x021035c0 in nsMacEventHandler::UpdateEvent(void)
 #14  0x02102164 in nsMacEventHandler::HandleOSEvent(EventRecord &)
 #15  0x02100fe4 in nsMacWindow::DispatchEvent(void *, int *)
 #16  0x02108c20 in DispatchOSEventToRaptor__16nsMacMessagePumpFR11EventRecordP15O
 #17  0x02107b9c in nsMacMessagePump::DoUpdate(EventRecord &)
 #18  0x021079ac in nsMacMessagePump::DispatchEvent(int, EventRecord *)
 #19  0x021077b0 in nsMacMessagePump::DoMessagePump(void)
 #20  0x0210712c in nsAppShell::Run(void)
 #21  0x0202d20c in nsAppShellService::Run(void)
 #22  0x004cbaec in main1(int, char **, nsISupports *)
 #23  0x004cc52c in main

Thread 1:
 #0   0x7000497c in syscall
 #1   0x70557600 in BSD_waitevent
 #2   0x70554b80 in CarbonSelectThreadFunc
 #3   0x7002054c in _pthread_body

Thread 2:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x705593ec in CarbonOperationThreadFunc
 #3   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x70283ea4 in TSWaitOnConditionTimedRelative
 #3   0x7027d748 in TSWaitOnSemaphoreCommon
 #4   0x702c2078 in TimerThread
 #5   0x7002054c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x70250ab0 in TSWaitOnCondition
 #3   0x7027d730 in TSWaitOnSemaphoreCommon
 #4   0x70243d14 in AsyncFileThread
 #5   0x7002054c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7055b884 in CarbonInetOperThreadFunc
 #3   0x7002054c in _pthread_body

PPC Thread State:
  srr0: 0x0232395c srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x20000018   lr: 0x02310ac0  ctr: 0x02323950   mq: 0x00000000
    r0: 0x02323950   r1: 0xbfffec60   r2: 0x02350000   r3: 0x00000000
    r4: 0xbfffec98   r5: 0xffffffff   r6: 0x0234ed34   r7: 0x030fe6fc
    r8: 0x00000004   r9: 0x80240e10  r10: 0x000008e5  r11: 0x834e142c
   r12: 0x02349420  r13: 0x00000000  r14: 0x00000000  r15: 0x00000000
   r16: 0x00000000  r17: 0x00000000  r18: 0x00000000  r19: 0x00000000
   r20: 0x00000000  r21: 0x00000000  r22: 0x02e544b0  r23: 0xbffff184
   r24: 0xbffff078  r25: 0x02e544b0  r26: 0x03c80900  r27: 0xbfffee88
   r28: 0xbfffee80  r29: 0xbfffed64  r30: 0x02e52600  r31: 0xbfffece8

**********
Keywords: stackwanted

Comment 2

17 years ago
makes sense, we cached the screen, the os released it, we used it, the os shot 
us for being silly.
Assignee: jaggernaut → pinkerton
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: crash when removing display from dualhead setup with mozilla running → crash when removing display from dualhead setup with mozilla running [@nsScreenMac::GetPixelDepth]
Target Milestone: --- → Future
(Reporter)

Comment 3

16 years ago
This bug seems to have magically fixed itself as of build 20020624 on 10.1.5. I
can't reproduce the bug anymore.

Comment 4

15 years ago
This bug happens also on windows XP with the latest 1.4b build, when mozilla
windows are left open on the second (detached) screen. 

Comment 5

15 years ago
It's also happening on Win2K SP4 with 1.6

Updated

15 years ago
Blocks: 236647

Comment 6

11 years ago
any "dualees" who can test this
Assignee: mikepinkerton → jag
QA Contact: jrgmorrison → xptoolkit.widgets

Comment 7

11 years ago
sure, get me a license for os x 10.4 :(. I have 10.3.9 and someone dropped support for me and my dual display g5.
Assignee: jag → nobody

Comment 8

9 years ago
The original reporter no longer sees this, so WFM.

Also: 
* Mozilla Corporation is full of people who use Mac laptops with multiple monitors and I think one of them would have commented by now if they were still seeing issues like this ;)
* nsScreenMac no longer exists.
* GetPixelDepth still exists but is responsible for 0 crash reports in the last week.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@nsScreenMac::GetPixelDepth]
You need to log in before you can comment on or make changes to this bug.