Closed Bug 1357489 Opened 3 years ago Closed 3 years ago

Downloading a file from Flash application with Firefox 64 bits is broken (slowness, "You don't have permission to save in this location")

Categories

(Core :: Plug-ins, defect)

52 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1284897

People

(Reporter: davirichar, Unassigned)

References

Details

(Keywords: 64bit, Whiteboard: sbwn1)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170323105023

Steps to reproduce:

1 - Go on this website (for example): http://sfbgames.com/chiptone/
2 - Generate a sound
3 - Click on the button "Save .WAV"
4 - You can browse anywhere you want, you get a message saying that you do not have the rights to save anything in that folder or location when you try to save.


Actual results:

4 - You can browse anywhere you want, you get a message saying that you do not have the rights to save anything in that folder or location when you try to save.


Expected results:

Simply save the file.
Works for me, saved to desktop, with Firefox 54.0a2 (2017-04-17) (32 bit) & 52.0.2 (32 bit) with Flash 25.0.0.148.
It appears only with Firefox 64 bits (and Flash 32 bits in my case). When the save file dialog box is open, CPU use increases and browsing folders to save the file is slow/buggy.
Component: Untriaged → Plug-ins
OS: Unspecified → Windows 10
Product: Firefox → Core
Hardware: Unspecified → x86
Summary: Cannot download files to computer on certain websites → Downloading a file from Flash application with Firefox 64 bits is broken (slowness, "You don't have permission to save in this location")
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true
Hardware: x86 → x86_64
Jim, didn't Bob or Handyman fix some bugs related to saving files from Flash? I can't find the bug #s.
Blocks: win64-rollout
No longer blocks: tracking_win64
Flags: needinfo?(jmathies)
Keywords: 64bit
David, please take a look, see if you can diagnose what's different here from bug 1284897.
Depends on: 1284897
Flags: needinfo?(jmathies) → needinfo?(davidp99)
Whiteboard: sbwn1
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(davidp99)
Resolution: --- → DUPLICATE
Duplicate of bug: 1284897
Explanation: This was fixed in bug 1284897, which is in 54 and we didnt uplift.
You need to log in before you can comment on or make changes to this bug.