Animated alert showing multiple accounts on one line

VERIFIED FIXED in mozilla1.0

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Scott MacGregor, Assigned: Scott MacGregor)

Tracking

Trunk
mozilla1.0
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ADT2])

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
The UE spec says that we are only going to show the animated alert for the first
account which has new mail. Due to a race condition, if you have several
accounts with the same biff interval, your alert would have text for both
accounts and they would be merged together on one big line. 

We need to just show the text for the first account.

Patch is trivial.
(Assignee)

Comment 1

16 years ago
Created attachment 77881 [details] [diff] [review]
Only show the text for the first account with new mail
(Assignee)

Comment 2

16 years ago
accepting.
Status: NEW → ASSIGNED
Keywords: nsbeta1
QA Contact: olgam → gchan
Target Milestone: --- → mozilla1.0

Comment 3

16 years ago
*** Bug 134416 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
Discussed in Mail News bug mtg with Engineering QA and PjM.  Decided to ADT2 and
plus this bug.
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [ADT2]

Comment 5

16 years ago
I think instead of finalText here

+        if (animatedAlertText.IsEmpty()) // if we haven't filled in the 
animated alert text yet
+          animatedAlertText = finalText;

it should be
           animatedAlertText = toolTipText

right ? otherwise we are going to skip all that truncation logic
(Assignee)

Comment 6

16 years ago
actually I WANT to skip all of that truncation logic. The code you are looking
at builds the tooltip text for the biff icon in the system tray. Windows limits
you to  128 characters in that tooltip. So there's lots of code in there for
only listing as many accounts as will fit in 128 characters for the tooltip.

This bug fix is for the animated alert text and has nothing to do with the
tooltip nor does it have the 128 character limitation. I just want the text from
the first account and not the tooltip text which has multiple accounts. Hope
that helps clarify. 

Comment 7

16 years ago
Comment on attachment 77881 [details] [diff] [review]
Only show the text for the first account with new mail

thanks for the clarification, r=naving
Attachment #77881 - Flags: review+

Comment 8

16 years ago
Comment on attachment 77881 [details] [diff] [review]
Only show the text for the first account with new mail

sr=bienvenu
Attachment #77881 - Flags: superreview+
(Assignee)

Comment 9

16 years ago
This has been checked into the. Leaving open until I get it into the moz 1.0 branch.

Comment 10

16 years ago
*** Bug 137299 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

16 years ago
keyword pixie dust to put on the adt1.0.0 radar
Keywords: adt1.0.0

Comment 12

16 years ago
adt1.0.0+ (on ADT's behalf) for checkin into the 1.0 branch. Pls check this in
to the branch today. After it is checked in, pls add fixed1.0.0. Once QA has
verified it on the branch, then add verified1.0.0.
Keywords: adt1.0.0 → adt1.0.0+
(Assignee)

Comment 13

16 years ago
This should be marked fixed since it is fixed on the trunk. Once QA has had a
chance to look at it I'll petition drivers for the branch. 
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Windows 2000, Windows NT 4.0, Windows 98, Windows XP...

I've verified *on the trunk* that if you have multiple new messages on multiple
accounts, we only display the 'username has x new messages' hyperlink for the
first account that has mail.  The other account, if it also has mail, has the
information in the tooltip, along with the first account.

Thanks to Gary for verification on Windows NT 4.0.

Verified with trunk build 2002-04-16-03.
QA Contact: gchan → stephend
Verified
Status: RESOLVED → VERIFIED

Comment 16

16 years ago
Comment on attachment 77881 [details] [diff] [review]
Only show the text for the first account with new mail

a=asa (on behalf of drivers) for checkin to the 1.0 branch
Attachment #77881 - Flags: approval+
(Assignee)

Comment 17

16 years ago
fixed on the 1.0 branch
Keywords: adt1.0.0+ → fixed1.0.0
Tested this on:

Branch 1.0.0 commercial build 2002-04-20-06 using:

Windows XP, Windows 2000, Windows 98, and Windows NT 4.0

With multiple accounts receiving new mail, we only show them in the system tray
notification icon's tooltip.  The alert itself only contains the 1st account
which has mail.

Verified FIXED on the branch and trunk, so replacing fixed1.0.0 keyword with
verified1.0.0
Keywords: fixed1.0.0 → verified1.0.0
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.