Throttle read from sockets/streams of requests belonging to background tabs

RESOLVED DUPLICATE of bug 1365307

Status

()

Core
Networking
P2
normal
RESOLVED DUPLICATE of bug 1365307
8 months ago
7 months ago

People

(Reporter: mayhemer, Assigned: mayhemer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-active])

(Assignee)

Description

8 months ago
One of active/background tabs prioritization bugs.

This would serve following purposes:
- give more bandwidth to the active tab
- preserve parallelism for background tabs
- lower CPU load for background tabs as parsers/decoders would get smaller chunks in longer intervals
Whiteboard: [necko-active]
(Assignee)

Updated

8 months ago
Assignee: nobody → honzab.moz

Comment 1

8 months ago
Will this increase the priority of a channel started while the tab is in the background, but then focused before the channel completes?
(Assignee)

Comment 2

8 months ago
Implementation notes:
- read small piece of data from a background socket
- call ResumeRecv() using a hearbeat timer (one for all is OK)
(Assignee)

Comment 3

8 months ago
(In reply to Ben Kelly [not reviewing due to deadline][:bkelly] from comment #1)
> Will this increase the priority of a channel started while the tab is in the
> background, but then focused before the channel completes?

yes, definitely.
(Assignee)

Updated

7 months ago
Blocks: 1362071
(Assignee)

Updated

7 months ago
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1365307
(Assignee)

Updated

7 months ago
No longer blocks: 1312741, 1362071
You need to log in before you can comment on or make changes to this bug.