Sourcemap is loaded from the wrong URL

RESOLVED DUPLICATE of bug 1355126

Status

()

Firefox
Developer Tools: Debugger
P2
normal
RESOLVED DUPLICATE of bug 1355126
7 months ago
6 months ago

People

(Reporter: artur, Unassigned)

Tracking

(Blocks: 1 bug)

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36

Steps to reproduce:

Debugging a Vaadin application using GWT SuperDevMode, which provides a source map for the original Java files


Actual results:

Fetched sourcemap JSON contains

"version":3,
"file":"sourceMap",
"lineCount":171409,
"sourceRoot":"http://localhost:9876/sourcemaps/com.vaadin.DefaultWidgetSet/",
"mappings": ...

Firefox debugger shows the sources as
* 127.0.0.1:9876 (correct)
  * sourcemaps/com.vaadin.DefaultWidgetSet/http://127.0.0.1:9876/sourcemaps/com.vaadin.DefaultWidgetSet

When trying to open a Java file in the debugger, a server requests is sent for
/sourcemaps/com.vaadin.DefaultWidgetSet/http:/127.0.0.1:9876/sourcemaps/com.vaadin.DefaultWidgetSet/com/vaadin/client/ui/FocusUtil.java
which obviously returns a 404 because the URL is wrong


This is with the latest update of Firefox Developer Edition (54.0a2)


Expected results:

The absolute URL should be used.
Debugger should show the correct URL instead of an absolute URL somehow appended to a relative URL with one slash removed.
Opening a Java file in the debugger should make a correct request and show the sources.

In Firefox 53.0, everything works as expected.

Updated

7 months ago
Component: Untriaged → Developer Tools: Debugger
Blocks: 1339970

Updated

7 months ago
Priority: -- → P2

Comment 1

6 months ago
Seems substantially the same as bug 1355126.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1355126
You need to log in before you can comment on or make changes to this bug.