Firefox manages to freeze my system even with 12GB of Main Memory

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
7 months ago
7 months ago

People

(Reporter: sh3rlock1, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink])

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170323105023

Steps to reproduce:

Open about 10 tabs on firefox (not blank) with atleast 3 heavy websites (by heavy I mean full with media), such as the likes of Facebook, Youtube, etc.


Actual results:

Do the steps above and the web browser starts to freeze. CPU consumption reaches as high as 80% and memory consumption reaches as high as 3GB. I tried closing and reopening Firefox but it happens again under 20 minutes. 

Plugins I use: Adblocker, Disconnect, HTTPS Everywhere.

I use same set of plugins (more actually) and much more tabs on Chrome and it never freezes and there is no need to restart the browser. I had been using Firefox since it was on version 1, but from the past few months I majorly use Chrome and waiting for this problem to be fixed, but it's still there, please fix it!!

Updated

7 months ago
Whiteboard: [MemShrink]

Comment 1

7 months ago
You need to open about:memory and save and attach a memory log when the memory use is very high.
But it could be related to your addons, it's better to test with a fresh profile.
Can you please attach memory reports from before the high cpu usage and after the high cpu usage? Are you on ESR 52? We've fixed similar issues on release 53 if you can upgrade to that.
Flags: needinfo?(sh3rlock1)
(Reporter)

Comment 3

7 months ago
I have updated to FF53 which was released yesterday:
1. I can see the difference, it's faster than before but the browser still struggles to scroll smoothly on pages with media.
2. I will report with the memory info if the browser reaches at high memory consumption.
3. This was a new install of Firefox, I am using the min set of plugins. (Lastpass, Adblock, HTTPS everywhere) I have a larger set of plugins on other browser but it still manages to survive and work a lot better than FF. And if I were to remove the plugins then what's the point of having plugin support in the first place.
4. I also use Firefox Mobile (Aurora version) and it's great!
Flags: needinfo?(sh3rlock1)
I'm going to close this for now, but please feel free to reopen if you see issues again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.