Closed Bug 1357664 Opened 2 years ago Closed 2 years ago

Don't expire all relations for expired icons when updating icons for a specific page

Categories

(Toolkit :: Places, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: mak, Assigned: mak)

References

Details

(Whiteboard: [fxsearch])

Attachments

(1 file)

There's a problem in the association query, when we update icons for a page, we should remove all the relations for the expired icons associated to that page. The problem is that we instead remove all the relations for the expired icons for any page.
This means that if I have 2 bookmarks to bugzilla entries and I visit one, both relations are expired, but only one is restored to the new icon.
Comment on attachment 8859481 [details]
Bug 1357664 - Don't delete all relations to expired icons when updating icons for a specific page.

https://reviewboard.mozilla.org/r/131504/#review134610

LGTM
Attachment #8859481 - Flags: review?(adw) → review+
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/ad7d2ae91ce6
Don't delete all relations to expired icons when updating icons for a specific page. r=adw
https://hg.mozilla.org/mozilla-central/rev/ad7d2ae91ce6
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.