7627d3407d54 cause inoperable bughunter workers when worker table is empty in a new bughunter database

RESOLVED FIXED

Status

Testing
Sisyphus
RESOLVED FIXED
8 months ago
8 months ago

People

(Reporter: Tomcat, Assigned: bc)

Tracking

Version 3
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 months ago
Steps to reproduce:
-> Clean/empty worker table
-> start workers

results in error:

main: exception Worker matching query does not exist.: Traceback (most recent call last):
  File "crashworker.py", line 1026, in main
    this_worker.doWork()
  File "crashworker.py", line 824, in doWork
    self.freeOrphanJobs()
  File "crashworker.py", line 752, in freeOrphanJobs
    if sitetestrun_row.worker.state in ('waiting', 'dead', 'zombie', 'disabled'):
  File "/usr/lib64/python2.7/site-packages/django/db/models/fields/related_descriptors.py", line 179, in __get__
    rel_obj = qs.get()
  File "/usr/lib64/python2.7/site-packages/django/db/models/query.py", line 385, in get
    self.model._meta.object_name
DoesNotExist: Worker matching query does not exist.

seems it nails to
https://hg.mozilla.org/automation/sisyphus/annotate/7627d3407d54/python/sisyphus/automation/crashtest/crashworker.py  

because without 7627d3407d54 applied it works
(Reporter)

Updated

8 months ago
Flags: needinfo?(bob)
(Assignee)

Comment 1

8 months ago
Thanks. Is this blocking you? If not, I'll get to it in a day or so. Otherwise I'll put it at the front of the queue.
Assignee: nobody → bob
Status: NEW → ASSIGNED
Flags: needinfo?(bob)
(Reporter)

Comment 2

8 months ago
(In reply to Bob Clary [:bc:] from comment #1)
> Thanks. Is this blocking you? If not, I'll get to it in a day or so.
> Otherwise I'll put it at the front of the queue.

oh not really blocking since i have the workaround with backing out that one changeset :)
(Assignee)

Comment 3

8 months ago
Created attachment 8859968 [details] [diff] [review]
Bug-1357686.patch
Attachment #8859968 - Flags: review?(cbook)
(Reporter)

Comment 4

8 months ago
Comment on attachment 8859968 [details] [diff] [review]
Bug-1357686.patch

Review of attachment 8859968 [details] [diff] [review]:
-----------------------------------------------------------------

looks good!
Attachment #8859968 - Flags: review?(cbook) → review+
(Reporter)

Comment 5

8 months ago
 https://hg.mozilla.org/automation/sisyphus/rev/7aed1ad9a85f82563793c46310f3665487eed139

also verified fixed - its working now again! thanks bc!
Status: ASSIGNED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.