[regression] TopSites/Highlight queries fail sometimes resulting in a default state

RESOLVED DUPLICATE of bug 1357761

Status

()

Firefox for iOS
Home screen
P2
normal
RESOLVED DUPLICATE of bug 1357761
8 months ago
8 months ago

People

(Reporter: farhan, Unassigned)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios8.0+)

Details

(Whiteboard: [mobileAS])

(Reporter)

Description

8 months ago
Sometimes while using Top Sites the panel will refuse to load any content and show the default state with default top sites and no highlights. 

This might be related to the metadata table causing the query to fail. Both Bryan Bell and I experienced this issue. I haven't been able to reproduce this issue reliably, But it happened to me after tapping on a highlight or topsite and going back to the TopSites home panel. 

Also simply reloading the panel by opening a new tab or switching back to a panel doesnt load anything. Going to the history panel shows visited sites but the topsites is still empty.
(Reporter)

Updated

8 months ago
tracking-fxios: --- → 8.0+
See Also: → bug 1357761
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1357761
You need to log in before you can comment on or make changes to this bug.