"visibility: hidden" does not hide table borders with "border-collapse: collapse"

RESOLVED FIXED in mozilla1.0

Status

()

Core
Layout: Tables
P3
normal
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Heribert Schuetz, Assigned: Bernd)

Tracking

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [FIXED_ON_TRUNK])

Attachments

(2 attachments, 1 obsolete attachment)

710 bytes, text/html
Details
1.64 KB, patch
karnaze (gone)
: review+
Marc Attinasi
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
In the following example only the table content is hidden, but not the border:

<table style="border-collapse: collapse; border: 1px solid black; visibility:
hidden;"><td>XXXXX</table>

If I understand the specs correctly, mozilla should hide the border here (and IE
actually does).

Comment 1

16 years ago
Confirmed on Win2K 2002040608; setting OS and Platform to All.

Is this the right component, or should it go to HTML Tables?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All

Comment 2

16 years ago
Created attachment 78111 [details]
Testcase showing bug
Reassigning to Karnaze.
Assignee: kmcclusk → karnaze
*** Bug 138953 has been marked as a duplicate of this bug. ***
Component: GFX Compositor → HTMLTables
QA Contact: petersen → amar
(Assignee)

Comment 5

16 years ago
Created attachment 80297 [details] [diff] [review]
patch
(Assignee)

Comment 6

16 years ago
accepting the bug
Assignee: karnaze → bernd.mielke

Comment 7

16 years ago
Comment on attachment 80297 [details] [diff] [review]
patch

r=karnaze
Attachment #80297 - Flags: review+
(Assignee)

Comment 8

16 years ago
Created attachment 80792 [details] [diff] [review]
patch cleaned up
Attachment #80297 - Attachment is obsolete: true
(Assignee)

Comment 9

16 years ago
the revised patch has passed the regression tests and the test list from bug 41262.
Status: NEW → ASSIGNED

Comment 10

16 years ago
Comment on attachment 80792 [details] [diff] [review]
patch cleaned up

r=karnaze
Attachment #80792 - Flags: review+

Comment 11

16 years ago
Comment on attachment 80792 [details] [diff] [review]
patch cleaned up

sr=attinasi
Attachment #80792 - Flags: superreview+
*** Bug 141220 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 13

16 years ago
fix checked in on trunk 
(Assignee)

Comment 14

16 years ago
branch checkin has been denied. 

Bernd Mielke wrote:

>
> Hi,
>
> is it possible to approve 
> http://bugzilla.mozilla.org/show_bug.cgi?id=135782? It got r=karnaze 
> and sr=attinasi. It fixes real pages, like the duped bug with 
> dhtmlkitchen shows. The risk seems to me small. The patch is already 
> on trunk
>
> Thanks
>
> Bernd
>
Not critical to 1.0.

--Asa
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
*** Bug 144949 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Priority: -- → P3
Whiteboard: [FIXED_ON_TRUNK]
Target Milestone: --- → mozilla1.0

Comment 16

16 years ago
User-Agent: 
Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0) Gecko/20020529


URL:
http://dhtmlkitchen.com/css/positioning/

description:
  there are several tables that are hidden in divs. Each table has a border
attribute. The tables are hidden by inheriting the visibility from their
ancestor div. The borders of said tables are visible.

I don't know if this bug still affects other platforms, I can only verify that
the table borders are visible in the User-Agent noted above.

Comment 17

16 years ago
Tested in Netscape 6.2.2 Windows and found no problems. Tested in Netscape 7.0 
first release and Mozilla 1.1 final and found the problem had re-emerged.
The code I used to test is:
<html>
  <body>
              	                     
<table cellspacing="0" cellpadding="0" border="0"
 style="border-top: 1px solid black; width: 165px; border-collapse: collapse; 
visibility: hidden;">
        <tbody>
         <tr>
           <td>&nbsp;<br>
          </td>
         </tr>
                   
  </tbody>              
</table>
                          <br>
   
</body>
</html>
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 18

16 years ago
Peter, both those versions are months old.  Don't act on a bug unless you test
it using a nightly build.

Works correctly (no borders shown) in nightly builds, Win2K and MacOS9.

Re-resolving FIXED.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.