Some images are rendered incorrectly (likely color-management related)

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: Adam Batkin, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8859805 [details]
gamepad.png

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170403080404

Steps to reproduce:

Visit an affected image, for example:
https://cdn.arstechnica.net/wp-content/uploads/2016/12/DSC06025-980x551.jpg


Actual results:

Image is waaaay too dark


Expected results:

Image should look "normal" (see attachment for example)
(Reporter)

Comment 1

a year ago
Both screenshots are taken from the same system (firefox-52.0.2-2.fc25.x86_64 on Fedora 25 / 4.10.8-200.fc25.x86_64)

The one on the left is with gfx.color_management.mode set to the default (2) and the one on the right is with gfx.color_management.mode explicitly set to 0.

As you can see, Firefox is basically unusable in this instance, unless color-management is disabled, and this is the case with many of the images on ArsTechnica (I haven't noticed this on other websites).
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0 (Fedora 23 & Ubuntu 14.04)

I have tested your issue on latest Firefox release v53 and latest Nightly (Build ID: 20170424030211) and could not reproduce it. I have followed the steps from comment 0 and tried them on Fedora 23 and Ubuntu 14.04. The picture was clearly visible and gfx.color_management.mode was set to 2.

Is this still reproducible on your end ? If yes, can you please retest this using latest Firefox release and latest Nightly build (https://nightly.mozilla.org/) and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/AR5o9d).
Flags: needinfo?(adam)
(Reporter)

Comment 3

a year ago
It seems to be resolved now. Which is interesting because this has been bugging me for months, and I've even seen other people on the ArsTechnica comments area complaining about the same issue.
Flags: needinfo?(adam)
(Reporter)

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.