On macOS Sierra, single mouse wheel movements are ignored

RESOLVED DUPLICATE of bug 1355340

Status

()

Core
Widget: Cocoa
RESOLVED DUPLICATE of bug 1355340
a year ago
a year ago

People

(Reporter: sausagefactory0, Unassigned)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170413192749

Steps to reproduce:

• Find a computer with macOS Sierra (10.12.4)
• Launch latest stable version of Firefox
• Open any page which is taller than window height
• Spin mouse wheel by exactly 1 "click" (don't know how it's called in English but you know that mouse wheel movement is discrete, and this means spin by smallest detectable amount)

On all previous versions of OS X, this problem didn't happen.


Actual results:

Nothing


Expected results:

Page should scroll by a small amount
(Reporter)

Comment 1

a year ago
Keep in mind that this is not an impossible obstacle put by Apple; many other applications somehow figured how to function correctly under the new macOS. For example, IntelliJ IDEA CE, Transmission, mpv (video player) all detect mouse wheel movement correctly, so at least it's possible to take a look how they did it. (all 3 examples are free and open source)
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:52.0) Gecko/20100101 Firefox/52.0

I have tested this issue on Mac OS 10.12 with the latest Firefox release (53.0), Firefox (52.0) and the latest Nightly (55.0a1-20170424030211) and managed to reproduce it. 
The issue is reproducible on the latest Firefox Release, when spinning the mouse wheel exactly one "click" as mentioned in the description, the page doesn't scroll.
However, the issue is no longer reproducible on the latest Nightly.

I've performed a regression, the results is below:

First good revision: 73752931e273091185e1e4b5231c28beed657cc8 (2017-04-24)
Last bad revision: 070fc3c2f8400c09f1037f5444c3d33b499e7128 (2017-04-23)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=070fc3c2f8400c09f1037f5444c3d33b499e7128&tochange=73752931e273091185e1e4b5231c28beed657cc8

Judging by the pushlog, the fix for this bug has been mentioned here:
https://bugzilla.mozilla.org/show_bug.cgi?id=1355340

Considering this, I will mark this issue as a duplicate of that bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Component: Untriaged → Widget: Cocoa
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1355340
You need to log in before you can comment on or make changes to this bug.