Closed Bug 1358011 Opened 3 years ago Closed 2 years ago

frames() timing function not rendered correctly in keyframe view

Categories

(DevTools :: Inspector: Animations, defect, P3)

defect

Tracking

(firefox55 verified)

VERIFIED FIXED
Firefox 55
Tracking Status
firefox55 --- verified

People

(Reporter: birtles, Assigned: daisuke)

Details

Attachments

(3 files)

Attached file frames-test.html
Compare the keyframe view for each of the animations in the attached test case. The first animation which uses the frames() timing function should show a stepped graph but it appears to be linear instead.
Priority: -- → P3
Assignee: nobody → dakatsuka
Comment on attachment 8875086 [details]
Bug 1358011 - Part 1: Handle frames() timing function.

https://reviewboard.mozilla.org/r/146452/#review150680
Attachment #8875086 - Flags: review?(pbrosset) → review+
Comment on attachment 8875087 [details]
Bug 1358011 - Part 2: Add test for frames() timing function.

https://reviewboard.mozilla.org/r/146454/#review150682
Attachment #8875087 - Flags: review?(pbrosset) → review+
Thank you, Patrick!
Pushed by dakatsuka@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8880a286e471
Part 1: Handle frames() timing function. r=pbro
https://hg.mozilla.org/integration/autoland/rev/c8fa4dd82f46
Part 2: Add test for frames() timing function. r=pbro
https://hg.mozilla.org/mozilla-central/rev/8880a286e471
https://hg.mozilla.org/mozilla-central/rev/c8fa4dd82f46
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
I have successfully reproduced this bug with Nightly 55.0a1 (2017-04-19) (32-bit) on windows 10(32bit)

this bug is verified fix with  latest Nightly 55.0a1 (2017-06-09) (32-bit)

Build ID: 20170609030207
Mozilla/5.0 (Windows NT 10.0; rv:55.0) Gecko/20100101 Firefox/55.0
QA Whiteboard: [bugday-20170607]
I have successfully reproduced this bug with Nightly 55.0a1 (2017-04-19) on 64bit Linux following the instruction from comment 0

This bug is now verified as fixed with latest Nightly 55.0a1

Build ID 	20170609100251
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
As per Comment 8 and Comment 9, I am marking this bug as verified fixed.
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.