Closed Bug 1358020 Opened 3 years ago Closed 3 years ago

Permaorange in webdriver/actions/special_keys.py when Gecko 55 merges to beta 2017-06-12

Categories

(Testing :: Marionette, defect)

55 Branch
defect
Not set

Tracking

(firefox-esr45 unaffected, firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55+ fixed)

RESOLVED FIXED
mozilla55
Tracking Status
firefox-esr45 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 + fixed

People

(Reporter: philor, Assigned: maja_zf)

References

Details

Attachments

(1 file)

https://treeherder.mozilla.org/logviewer.html#?job_id=92882606&repo=try (should be possible to reproduce it locally or in try pushes by changing /config/milestone.txt from 55a1 to 55, since that's what does most of the changes).

[Tracking Requested - why for this release]:

Merge permaorange, closed tree, delayed b1, wailing and gnashing of teeth.
Flags: needinfo?(mjzffr)
Tracking 55+ for this permaorange, especially to avoid delays in B1.
I ran this on a one-click loaner and I can see that sending the F10 key to the input field causes the "File" menu to become activated in the browser. This interferes will all subsequent keys tests. (I can reproduce this behaviour manually as well.) I wonder why this never showed up in previous builds.

I'm technically not here today. :( Since this is time-sensitive, I will ask whimboo and ato to take a look. If no quick workaround is available, I suggest we disable the test and fix it in a follow-up bug.
Flags: needinfo?(mjzffr) → needinfo?(hskupin)
Time-sensitive, but not that sort of time: you have 7 weeks, until 2017-06-12.
Thanks for the clarification. For the future, I'll classify "wailing and gnashing of teeth" as "not urgent". :)
Assignee: nobody → mjzffr
Flags: needinfo?(hskupin)
Whatever was causing this must have affected something else too, since somebody fixed it somewhere along the line.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Fun! Must have been "fixed" by backing something out, and that something must have relanded, because it's back, https://treeherder.mozilla.org/logviewer.html#?job_id=99654081&repo=try
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I remember that James landed some other stuff recently again for web-platform-tests. Maybe those caused those issues?
When it was "fixed", that's because the tests were expected to fail (the harness was broken due to merge conflicts from upstream wpt). Now the harness is fixed with what James landed recently, so the tests are running and it's the same issue as described before in Comment 2.
I think this patch should do it: https://hg.mozilla.org/try/rev/f4095e3030170bfdf6cd58f106e1da9562c332e1

Green for me on try, but I'm not sure I'm getting the "beta" scenario right in that try push. philor, could you let me know whether the above greens things up for you?
Flags: needinfo?(philringnalda)
(In reply to Phil Ringnalda (:philor) from comment #10)
> No joy,
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=20764a7447d6225d5f451a1cb696fdf475ee938c&filter-
> searchStr=wd

Ah, preventing on the keyup was too late. Fixed now. This wfm on one-click loaner from your try push: https://reviewboard-hg.mozilla.org/gecko/rev/79e4e333b5a5b692f4015c68435b957c8a66b35e
Comment on attachment 8871782 [details]
Bug 1358020 - Prevent default behaviour when testing function keys;

https://reviewboard.mozilla.org/r/143238/#review147014
Attachment #8871782 - Flags: review?(ato) → review+
Pushed by philringnalda@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/261836433b94
Prevent default behaviour when testing function keys; r=ato
https://hg.mozilla.org/mozilla-central/rev/261836433b94
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.