Crash in CoreGraphics@0x3457f1

RESOLVED WORKSFORME

Status

()

P3
critical
RESOLVED WORKSFORME
2 years ago
9 months ago

People

(Reporter: stephend, Unassigned)

Tracking

({crash, reproducible})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-bcd54559-153c-44d4-a732-c448c0170420.
=============================================================

macOS version: 10.12.5 Beta (16F60a)

Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:55.0) Gecko/20100101 Firefox/55.0

Steps to Reproduce:

1. Load https://github.com/mozilla/stubattribution-tests/blob/master/tests/test_stub_attribution_organic.py
2. Command + P; leave options default
3. Click OK to print

Actual Results:

Crash in:

Frame 	Module 	Signature 	Source
Ø 0 	CoreGraphics 	CoreGraphics@0x3457f1 	
1 	XUL 	CreateCTFontFromCGFontWithVariations 	gfx/cairo/cairo/src/cairo-quartz-font.c:350
2 	XUL 	_moz_cairo_quartz_font_face_create_for_cgfont 	gfx/cairo/cairo/src/cairo-quartz-font.c:402
3 	XUL 	mozilla::gfx::ScaledFontBase::PopulateCairoScaledFont() 	gfx/2d/ScaledFontBase.cpp:73
4 	XUL 	mozilla::gfx::UnscaledFontMac::CreateScaledFont(float, unsigned char const*, unsigned int) 	gfx/2d/ScaledFontMac.cpp:499
5 	XUL 	mozilla::gfx::RecordedScaledFontCreation::PlayEvent(mozilla::gfx::Translator*) const 	gfx/2d/RecordedEvent.cpp:1737
6 	XUL 	mozilla::layout::PrintTranslator::TranslateRecording(std::__1::basic_istream<char, std::__1::char_traits<char> >&) 	layout/printing/PrintTranslator.cpp:60
7 	XUL 	mozilla::layout::RemotePrintJobParent::PrintPage(nsCString const&) 	layout/printing/ipc/RemotePrintJobParent.cpp:128
8 	XUL 	mozilla::layout::RemotePrintJobParent::RecvProcessPage(nsCString const&) 	layout/printing/ipc/RemotePrintJobParent.cpp:88
9 	XUL 	mozilla::layout::PRemotePrintJobParent::OnMessageReceived(IPC::Message const&) 	obj-firefox/ipc/ipdl/PRemotePrintJobParent.cpp:245
10 	XUL 	mozilla::ipc::MessageChannel::DispatchAsyncMessage(IPC::Message const&) 	ipc/glue/MessageChannel.cpp:1903
11 	XUL 	mozilla::ipc::MessageChannel::DispatchMessage(IPC::Message&&) 	ipc/glue/MessageChannel.cpp:1838
12 	XUL 	mozilla::ipc::MessageChannel::MessageTask::Run() 	ipc/glue/MessageChannel.cpp:1744
13 	XUL 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp:1270
14 	XUL 	NS_ProcessPendingEvents(nsIThread*, unsigned int) 	xpcom/threads/nsThreadUtils.cpp:331
15 	XUL 	nsBaseAppShell::NativeEventCallback() 	widget/nsBaseAppShell.cpp:97
16 	XUL 	nsAppShell::ProcessGeckoEvents(void*) 	widget/cocoa/nsAppShell.mm:399
Ø 17 	CoreFoundation 	CoreFoundation@0xa7320 	
Ø 18 	CoreFoundation 	CoreFoundation@0x8821c 	
Ø 19 	CoreFoundation 	CoreFoundation@0x87715 	
Ø 20 	CoreFoundation 	CoreFoundation@0x87113 	
Ø 21 	HIToolbox 	HIToolbox@0x30ebb 	
Ø 22 	HIToolbox 	HIToolbox@0x30cf0 	
Ø 23 	HIToolbox 	HIToolbox@0x30b25 	
Ø 24 	AppKit 	AppKit@0x46a53 	
Ø 25 	AppKit 	AppKit@0x7c27ed 	
26 	XUL 	-[GeckoNSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] 	widget/cocoa/nsAppShell.mm:130
Ø 27 	AppKit 	AppKit@0x3b3da 	
28 	XUL 	nsAppShell::Run() 	widget/cocoa/nsAppShell.mm:673
29 	XUL 	nsAppStartup::Run() 	toolkit/components/startup/nsAppStartup.cpp:283
30 	XUL 	XREMain::XRE_mainRun() 	toolkit/xre/nsAppRunner.cpp:4549
31 	XUL 	XREMain::XRE_main(int, char**, mozilla::BootstrapConfig const&) 	toolkit/xre/nsAppRunner.cpp:4722
32 	XUL 	XRE_main(int, char**, mozilla::BootstrapConfig const&) 	toolkit/xre/nsAppRunner.cpp:4815
33 	firefox 	main 	browser/app/nsBrowserApp.cpp:236
34 	firefox 	start

NVIDIA GeForce GT 750M:

  Chipset Model:	NVIDIA GeForce GT 750M
  Type:	GPU
  Bus:	PCIe
  PCIe Lane Width:	x8
  VRAM (Total):	2048 MB
  Vendor:	NVIDIA (0x10de)
  Device ID:	0x0fe9
  Revision ID:	0x00a2
  ROM Revision:	3776
  Automatic Graphics Switching:	Supported
  gMux Version:	4.0.8 [3.2.8]
  Metal:	Supported
Keywords: reproducible
Priority: -- → P3
The URL in comment 0 is now 404.

Stephen, do you still have it around somewhere?
If so, does the crash still occur in a recent version of Firefox?
Flags: needinfo?(stephen.donner)
(Reporter)

Comment 2

9 months ago
(In reply to Mats Palmgren (:mats) from comment #1)
> The URL in comment 0 is now 404.
> 
> Stephen, do you still have it around somewhere?
> If so, does the crash still occur in a recent version of Firefox?

The permalink for the same test (code has slightly changed over the past year, of course) is here: https://github.com/mozilla/stubattribution-tests/blob/46716f85f0514d37da214baa3d85b5de19c2f728/tests/test_organic_flow.py

I tried just now and couldn't reproduce this crash (while at home), but I suspect it was while at work, connected to a Mozilla LAN printer.  I'll try again, there, tomorrow.  I'm also on High Sierra beta: 10.13.6 Beta (17G31f), running Nightly: Built from https://hg.mozilla.org/mozilla-central/rev/fa5724780fe76d6ccbbd08d978342a1db6a43d49 62.0a1 (2018-06-04) (64-bit)
Thanks, that be appreciated.  Fwiw, printing the new URL works
fine for me in 61.0b10 on OSX.
(Reporter)

Comment 4

9 months ago
Sorry for the delay; this WFM now with today's Nightly 64-bit build on macOS 10.13.6 Beta (17G31f)
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(stephen.donner)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.