Fennec is importing the profile from Release

VERIFIED FIXED

Status

()

P1
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: SimonB, Assigned: sleroux)

Tracking

unspecified
All
iOS

Firefox Tracking Flags

(fxios8.0+, fxios-v8.0 verified)

Details

(Whiteboard: [MobileCore])

(Reporter)

Description

a year ago
Build: f9f4cf1ba
Device: iPad Air 2
iOS: 10.3.1  

Prerequisites:
- Have no version of Firefox installed.

Steps to reproduce:
1. Install Firefox released version 7.2
2. Launch Firefox 7.2
3. Create some browsing data (Bookmarks, History)
4. Install and run latest master via Xcode

Actual results: 
- All the data created on the released version is displayed on master. 
- The “Whats's new in Firefox for iOS 2.0” page will open in a new tab on master. This page will not open when launching Firefox release for the first time.
- First Tour is not displayed on master.
Master first run:
https://pastebin.mozilla.org/9019507
(Assignee)

Comment 2

a year ago
I have a feeling this is because of the consolidation of the app groups into a single group since Xcode 8.3 was throwing a fit about this.
tracking-fxios: ? → 8.0+
Priority: -- → P1
Whiteboard: [MobileCore]
(Assignee)

Updated

a year ago
Assignee: nobody → sleroux
Status: NEW → ASSIGNED
Iteration: --- → 1.20
(Assignee)

Comment 3

a year ago
master d43c368f8106443f5d4d8fc99f1635c2e0fbc1fd
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Reporter)

Comment 4

a year ago
Verifying as fix on master d43c368f8.
Status: RESOLVED → VERIFIED
status-fxios-v8.0: affected → verified
Iteration: 1.20 → 1.21
You need to log in before you can comment on or make changes to this bug.