TalkBack broke with upgrade to 53.0

RESOLVED DUPLICATE of bug 1332731

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1332731
a year ago
a year ago

People

(Reporter: Christian von Roques, Unassigned)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(firefox53blocking verified, firefox54+ fixed)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20170307221322

Steps to reproduce:

Have Google Play upgrade Firefox for Android to version 53.0 and then try to use TalkBack to narrate any web page content.


Actual results:

When touching content, it receives *one* frame, but is neither narrated, nor receives the second TalkBack framing.

TalkBack does still work for Firefox's UI, just web page content is affected.


Expected results:

TalkBack should narrate (use Text-to-Speech on) the content touched (or otherwise navigated to).

This broke with last night's upgrade to 53.0.
Uninstalling and manually installing 52.0.2 restored TalkBack functionality.
What device, version of Android?
Flags: needinfo?(roques)
Hi Ioana, could your team try to repro this issue? 

Hi Seb, if we have a fix ready in time and it is deemed safe, we might include it the next dot release. Could you please help find a dev owner?
Flags: needinfo?(s.kaspari)
Flags: needinfo?(chiorean.ioana)
Flags: needinfo?(whuang)
Jim,
Not sure if this is relevant to Bug 1331946 but could you take a look?
Flags: needinfo?(nchen)
I think it's bug 1332731. Looks like it should have been uplifted to 53.
Flags: needinfo?(nchen)
I was able to repro this on Android 7.1.1 on a Nexus 5x with Fennec53. As mentioned in comment 0, the Firefox menu items are spoken out loud but the webpage contents are not.
status-firefox53: --- → affected
tracking-firefox53: --- → +

Updated

a year ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(whuang)
(Reporter)

Comment 6

a year ago
I'm using a Samsung Galaxy S5 (SM-G900F)
running Android 6.0.1 (Security Patch Level 1 February 2017) as provided by Samsung.
Build Number: MMB29M.G900F7ZHS1CQB2, with kernel 3.4.0-9889393.
SE for Android Status: Enforced SEPF_SECMOBILE_6.0.1_0032 Wed Feb 15 15:20:47 2017.

As TTS engine I'm using: IVONA Text-to-Speach HQ with Amy UK English beta as voice (Speech rate: fastest).
Flags: needinfo?(roques)
(Reporter)

Comment 7

a year ago
Last night's update of Firefox for Android Beta to 54.0b1 fixed the problem for me.
However, the official release 53.0 remains broken and unusable for blind users.
This sounds like a duplicate bug for 1332731. We should ship a dot release for 53 to fix this.
status-firefox54: --- → fixed
tracking-firefox53: + → blocking
tracking-firefox54: --- → +
Flags: needinfo?(s.kaspari)

Comment 9

a year ago
Oana - can you try this too ( as u succeed in reproducing the other bug)
Flags: needinfo?(chiorean.ioana) → needinfo?(oana.horvath)
Flags: needinfo?(oana.horvath) → needinfo?(bogdan.surd)
Device:
 - Nexus 9 (Android 7.1.1);
Builds:
 - Production 53;
 - Beta 54.0b2.

Hello,

 I could reproduce the issue in Comment 0 but I will agree with Liz in Comment 7 here and I think we can mark this as a duplicate of Bug 1332731, seeing as TalkBack works for web content in 54.0b2.
Bogdan - I don't understand here whether you're verifying that the fix is in 54.0b2, or not. You say that you can reproduce the issue in 54.0b2, but you also say that TalkBack works for web content.  Are you verifying the fix anywhere or are you still seeing that this is broken?
This isn't necessarily a duplicate bug. This bug says that web content is not showing at all to TalkBack users.    Bug 1332731 is specifically about checkbox behavior. So maybe some users can see web content and others can't.  

We need to clarify what the issues are and whether they are fixed, in both bugs!
Hey Liz,

 I've verified the same webpages with the production and the Beta build and TalkBack reads the content of the webpages in 54.0b2 but does not in 53. I did not verify if the fix was in, I assumed that the fix deployed in Bug 1332731 on 54.0b2 also fixed this issue.

 I could reproduce the issue described in Comment 0 in the production build, but I could not reproduce it in the Beta build. Sorry for not being clear on that part. 

 So this is still broken in production(53), but is fixed in Beta(54.0b2). 

 In Bug 1332731 I was talking about the check boxes not being read as check boxes but being read as check buttons. Hope this clears up everything.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(bogdan.surd)
Resolution: --- → DUPLICATE
Duplicate of bug: 1332731
OK, thank you Bogdan! I'm hoping this is fixed in 53.0.1 Fennec now. I hate to ask this again, but can you verify Talkback really is working in 53.0.1, now that we have the release out the door?
Flags: needinfo?(bogdan.surd)
status-firefox53: affected → fixed
Device: Honor 8 (Android 6.0)
Builds:
 - 53.0.1 (Build 2) & 53.0.1 (installed from Google Play)

Hello Liz,

 I've verified it again and it seems to be working fine, I did not encounter any problems.
status-firefox53: fixed → verified
Flags: needinfo?(bogdan.surd)
You need to log in before you can comment on or make changes to this bug.