consider adding GPU process information to about:support

RESOLVED FIXED in Firefox 55

Status

()

Core
Graphics
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: bkelly, Assigned: dvander)

Tracking

unspecified
mozilla55
Points:
---

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
A user asked on twitter yesterday how they could tell if their FF53 was using a separate GPU process as advertised in our blog posts.  I didn't have a good answer for them.  Starting in FF54 they can use about:memory to see, but it might be nice to add a row in about:support indicating the GPU process status.

Comment 2

a year ago
(In reply to Ben Kelly [not reviewing due to deadline][:bkelly] from comment #0)
> A user asked on twitter yesterday how they could tell if their FF53 was
> using a separate GPU process as advertised in our blog posts.  I didn't have
> a good answer for them.  Starting in FF54 they can use about:memory to see,
> but it might be nice to add a row in about:support indicating the GPU
> process status.

It might as well ask David for better answer.
Flags: needinfo?(dvander)
We made it nightly/aurora only since it also has a "kill process" button, but just exposing the pid seems fine.
Flags: needinfo?(dvander)
Assignee: nobody → dvander
Status: NEW → ASSIGNED
Duplicate of this bug: 1358304
Created attachment 8860241 [details] [diff] [review]
bug1358138.patch

Always show the pid (if one exists), but keep the terminate button aurora/nightly only.
Attachment #8860241 - Flags: review?(milan)
Attachment #8860241 - Flags: review?(milan) → review+

Comment 6

a year ago
Pushed by danderson@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5ed2f24d732f
Always show the compositor process PID in about:support. (bug 1358138, r=milan)

Comment 7

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5ed2f24d732f
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55

Comment 8

a year ago
> Target Milestone: --- → mozilla55

So, this will only available in Firefox 55 stable?
As I saw this patch here is IMHO simple, just a few lines,
and I was hoping (I have filed bug 1357744) that it would make it to Firefox 54 stable too.
You need to log in before you can comment on or make changes to this bug.