The metadata table fails to join on history data because the joining column (url) has different schemes

RESOLVED FIXED

Status

()

P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: farhan, Assigned: sleroux)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios8.0+)

Details

(Whiteboard: [mobileAS])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
When querying for highlights and topsites we use the metadata table to fetch additional information about a site. This info is stored in a metadata table with the columns (cache_key, url, site_title, site_image). 

The table is then joined in SQL with the site history table on the URL key. Which should work correctly but for some reason some sites that have https URLs in the site history table have http in the page metadata table. So joins end up failing and the metadata is never available. 

I noticed that this happened for me on https://theverge.com
(Assignee)

Updated

2 years ago
Assignee: nobody → sleroux
Status: NEW → ASSIGNED
(Assignee)

Updated

2 years ago
Iteration: --- → 1.19
tracking-fxios: --- → 8.0+
(Assignee)

Updated

2 years ago
Priority: P3 → P1
(Assignee)

Updated

2 years ago
Iteration: 1.19 → 1.20
(Reporter)

Updated

2 years ago
Attachment #8862128 - Flags: review?(fpatel) → review+
(Assignee)

Comment 2

2 years ago
master 6f9d154d1c35568968ba9c016d8ca24b4274ee07
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.