location bar results show duplicate entries for a single site

RESOLVED DUPLICATE of bug 1046074

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 1046074
8 months ago
8 months ago

People

(Reporter: brendan c, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 months ago
Created attachment 8860110 [details]
duplicated awesomebar entries 2.png

Location bar shows multiple entries for what in practice resolves to a single actual site. This wastes space in the Awesomebar results, lowering the signal-to-noise ratio of the results and making them less useful to users.

See for example the attached image. The string "face" is entered into the bar; the top three suggestions are:
1. "facebook.com/  -- Visit"
2. "Facebook -- https://www.facebook.com"
3. "facebook.com -- https://facebook.com"

At the very least, 1 and 3 are obviously redundant. Further, I suspect that with almost zero risk, we could (for the purposes of autocomplete suggestions) assume that in almost all cases a url without a subdomain refers to "www" -- so we should really be able to get this down to one list entry, giving us more room to show more useful results.
the first entry is http, the second one is https://www. the third one is https://.
There is absolutely nothing that guarantees those 3 are the same, so we'll always have risks, some websites are for sure differentiating some of those (especially http VS https).

I'm duping to bug 1046074 that is about www. that in general is less risky and we are already making that assumption in the urlbar.
I'm not sure for now we can do much about http/s since there's nothing that can tell us whether those pages are the same.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1046074
You need to log in before you can comment on or make changes to this bug.