java applets with <applet width=100%> won't resize properly.

VERIFIED DUPLICATE of bug 131065

Status

()

Core
Plug-ins
P3
normal
VERIFIED DUPLICATE of bug 131065
16 years ago
16 years ago

People

(Reporter: Dominik 'Aeneas' Schnitzer, Assigned: serge (gone))

Tracking

Trunk
mozilla1.0.1
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [java], URL)

(Reporter)

Description

16 years ago
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020405
BuildID:    20020405

Plugins dont resize properly with latest cvs. The plugin "area" seems to 
resize, but the plugin's resize function isn't called or the new plugin area
isn't reported to the plugin.

This isn't limited to 4.x plugins but also new 6.x ones.

This is happening for java applets with width=100% too: I noticed In my java
applet the resize event handler function is never called.
The applet should resize itself, but it doesn't.. My java applet resize()
handler is just on first loading.

Setting the applet size to 100% works in Netscape 4.x (Linux) and in the
Internet Explorer.

Reproducible: Always

Steps to Reproduce:
Easiest way to reproduce is:
 - load any pdf file, http://www.cdt.org/legislation/105th/privacy/64fr59888.pdf
 - let the adobe acrobat plugin load
 - resize the window: adobe acrobat wont resize itself to the correct browser size.

Comment 1

16 years ago
sounds like regression of bug 101974

Comment 2

16 years ago
handing over to serge
Assignee: beppe → serge
Priority: -- → P3
Target Milestone: --- → mozilla1.0.1
(Assignee)

Comment 3

16 years ago
test case is needed,
acrobat plugin resize problem bug 101974 is fixed.
(Reporter)

Comment 4

16 years ago
Hi,

here is the java testcase:
http://www.schnitzer.at/dominik/tmp/test.html

This is a quick hack. The current size of the applet is written in the applet
window, the blue bar on the right side indicates the current right border of the
applet. So you can see if the applet resizes.

I have tried it on Mozilla/Win32 too (JRE1.4 and 1.3.1): It works.
Resizing the applet works in Internet Explorer too.
It seems to be a Mozilla/Linux Bug only.

I had a look in "mozilla/modules/plugin/base/src", but couldn't pin the thing
down...

best,
aeneas.

Comment 5

16 years ago
Worksforme Build ID: 2002042608 (0.9.9+) trunk Windows 98. 

Can anyone confirm this on Linux or other platform?
Summary: acrobatreader, <applet width=100%> java applets or any plugin wont resize properly. → acrobatreader, <applet width=100%> java applets or any plugin won't resize properly.

Comment 6

16 years ago
Thx for bringing to my attendtion, Andrew. This is indeed a wfm. works on my 
linux 0426 branch build and mac 9.2 0426 branch build. 
I tested acrobat and it resizes properly with a browser window resize.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 7

16 years ago
above : i meant "attention" ;). Verif.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

16 years ago
hi,

as noted in comment #3, resizing acrobat reader already works. But resizing a
java applet with <applet width="100%"> does Not work.

Please hava a look at my "testcase-applet" at:
http://www.schnitzer.at/dominik/tmp/test.html

dominik.
Summary: acrobatreader, <applet width=100%> java applets or any plugin won't resize properly. → java applets with <applet width=100%> won't resize properly.
(Reporter)

Comment 9

16 years ago
I forgot to add that this is a Mozilla/Linux Bug only.
(Reporter)

Comment 10

16 years ago
reopening.

Please see comment #8 & #9 (resizing doesn't work for java applets, and it's a
linux bug only)
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 11

16 years ago
Happens for me too.

Updated

16 years ago
Whiteboard: [java]

Comment 12

16 years ago
this is not unique to Linux, marking as a dup of the more general cross-platform
bug on this issue

*** This bug has been marked as a duplicate of 131065 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 13

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.