Intermittent prompts for stored password when publishing a page.

VERIFIED DUPLICATE of bug 80652

Status

SeaMonkey
Composer
--
minor
VERIFIED DUPLICATE of bug 80652
16 years ago
13 years ago

People

(Reporter: TucsonTester1, Assigned: Charles Manske)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9+)
Gecko/20020405 Netscape6/6.2.1+
BuildID:    2002040503

The publishing feature is intermittently prompting for a password even if save
password is consistently checked.

Reproducible: Sometimes
Steps to Reproduce:
1.Install/Launch NS 6.2.1+
2.Launch a new Composer window and enter some content.
3.Click file | publish as...
4.Enter appropriate information to upload page to ftp site.
5.Enter user name and password and ensure "save password" is checked.
6.Publish page.
7.Reopen and edit page and publish again.....repeat.


Actual Results:  Occasionally there will be a prompt for the password.  I tried
to find some common factor here, but was unable to thus far.  It seems very random. 

Expected Results:  A saved password remains saved and does not prompt.

Comment 1

16 years ago
Is it just for the ftp protocol or does it also happen for http and https?
Is it specific to one particular server?
I think I've seen this problem also but I'm not 100% sure.
Summary: Intermittent prompts for stored password when publishing a page. → Intermittent prompts for stored password when publishing a page.

Comment 2

16 years ago
I am seeing this also on Win 2k using the 04-15 build.  I do not see this
problem when publishing via http, and I do not have access to a server that
allows https.  
Also, I only have one FTP server to try, so I cannot verify whether or not it is
specific to my server.

A couple things to note:
1. This only seems to happen if you leave the "HTTP address to browse to:" field
blank.
2. It only seems to happen when you are uploading a page with images.  

So my steps are:
1. Launch Composer
2. Type some text, and add an image
3. Click File - Publish As
4. Enter to a FTP URL to publish to, make sure there is no "HTTP address to
browse to:" listed, enter your username and password, and click the option to
save the password
5. Switch to the publish tab and give it a title and filename
6. Make sure "Include images and other files" is checked, and that it is set to
use the same location as the page 
7. Click on Publish
8. Close out of the publish progress dialog after the publish dialog is finished
9. Add some more text and another image to the page
10. Click File - Publish As, and verify the settings are the same as before, but
do not change any of them
11. Click on Publish
12. Repeat steps 8 - 10 as necessary (shouldn't take much more than 3 or 4 tries)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
I am also seeing this problem on the 04-13 1.0.0 branch build.
(Assignee)

Comment 4

16 years ago
I think you are seeing the extra prompts because of additional images.
We set username+password correctly for the image that is uploaded, but I suspect
that when we reset the image name as part of the upload process (now reletive to
new image location), those new URLs are triggering username prompts.
FTP doesn't keep an open "login" like HTTP does, thus each transfer is its own
ftp connection. Brade: does this sound right to you?

Comment 5

16 years ago
I think this is a general bug with ftp protocol and not at all related to
publishing.  I see this extra prompting in these cases:
 * loading html file in browser window
 * loading html file in Composer window
 * double-clicking image in Composer window

bbaetz--do you already have a bug on this issue or is this really an image lib
issue?
OS: Windows XP → All
Hardware: PC → All
If you don't explicitly add the username/pw as part of the upload request, you
will run into this due to bug 80652.
(Assignee)

Comment 7

16 years ago
Well, we can't insert the "username:password" into each destination image url,
so there's not much we can do about this.
Kathy: might as well dup this to bug 80652?
(Assignee)

Comment 8

16 years ago
Nothing we can do about this in Composer.

*** This bug has been marked as a duplicate of 80652 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

16 years ago
Don't think this bug is a dupe of 80652.  The key here is that these prompts 
only seem to happen when "HTTP address to browse to:" field is left blank.  
That seems to indicate there is an issue with Composer or publish regardless of 
ftp protocol.

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 10

16 years ago
No, I disagree! When you supply a valid HTTP "Address to browser to" then after
publishing, we switch the URL of the remote doc to the http address.
The images are now relative to the HTTP base URL and you don't get the password
prompts.
If that is missing, then the remote URL is the ftp publishing location. In that
context, all the image URLs are relative to that ftp address and thus are 
triggering the prompts for password for each image. 
The fact that it doesn't prompt when HTTP address is filled in is what *prooves*
it is is an FTP only problem.


*** This bug has been marked as a duplicate of 80652 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 11

16 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.