list-style-type: toggle(disc, circle, square); considered a CSS bug in debugger

RESOLVED INVALID

Status

()

Firefox
Developer Tools: CSS Rules Inspector
RESOLVED INVALID
8 months ago
7 months ago

People

(Reporter: Jim Michaels, Unassigned)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170413192749

Steps to reproduce:

list-style-type: toggle(disc, circle, square); considered a CSS bug in debugger


Actual results:

highlights circle as error.



Expected results:

should have allowed it

Updated

8 months ago
Component: Untriaged → Developer Tools: Debugger

Updated

8 months ago
Component: Developer Tools: Debugger → Developer Tools: CSS Rules Inspector

Comment 1

8 months ago
I suspect that Firefox just doesn't support toggle() here.
(Reporter)

Comment 2

8 months ago
it used to. what happened?
I can't find much docs about the toggle() function. It certainly does not seem to work in Firefox.

This spec from 2015 mentioned that toggle() is at risk and may be dropped:
https://www.w3.org/TR/2015/CR-css-values-3-20150611/

And this one from 2016 https://www.w3.org/TR/css3-values/ says that toggle() was dropped because of the lack of implementations.

So DevTools is doing the right thing here, it's showing that the property value is invalid, because Firefox does not support it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.