Closed Bug 1358626 Opened 3 years ago Closed 3 years ago

network.http.referer.XOriginPolicy=1 breaks external CSS on pages accessed via IPs instead of host name

Categories

(Core :: Networking: HTTP, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1354563

People

(Reporter: moz-bugs, Unassigned)

Details

CSS files are not loaded when network.http.referer.XOriginPolicy is set to 1, on pages accessed via their IPs.

testcase: http://78.46.244.89/bug.html

Things work fine if the pref is set to 0 or 2, or if the page is accessed through a host name instead of a IP (compare https://maltekraus.de/temp/bug.html).
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1354563
You need to log in before you can comment on or make changes to this bug.