1.43ms uninterruptible reflow at focusContent@resource://gre/modules/RemoteFinder.jsm:169:5

RESOLVED WORKSFORME

Status

()

defect
P4
normal
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: mconley, Unassigned)

Tracking

(Depends on 1 bug, Blocks 1 bug, {perf})

unspecified
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ohnoreflow][qf:p2][reserve-photon-performance])

Here's the stack:

focusContent@resource://gre/modules/RemoteFinder.jsm:169:5
close@chrome://global/content/bindings/findbar.xml:745:11
onxblkeypress@chrome://global/content/bindings/findbar.xml:1375:17
That line is this._browser.focus();
Depends on: 1356034
Flags: qe-verify?
Priority: -- → P2
Component: Untriaged → General
Component: General → Find Toolbar
Product: Firefox → Toolkit
Reporter

Updated

2 years ago
Whiteboard: [ohnoreflow][qf][photon-performance] → [ohnoreflow][qf:p1][photon-performance]
Priority: P2 → P3
Whiteboard: [ohnoreflow][qf:p1][photon-performance] → [ohnoreflow][qf:p1][reserve-photon-performance]
Flags: qe-verify? → qe-verify-
Whiteboard: [ohnoreflow][qf:p1][reserve-photon-performance] → [ohnoreflow][qf:p2][reserve-photon-performance]
Despite bug 1369140 landing, calling focusContent still seems to cause a reflow.
Reporter

Updated

2 years ago
Depends on: 1371371
Reporter

Updated

2 years ago
No longer depends on: 1356034
Priority: P3 → P4
Keywords: perf
I can't reproduce this anymore.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.