Expand the Personal Address Book widget and it crashes

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Address Book & Contacts
--
major
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: racham)

Tracking

({crash})

Trunk
mozilla1.0
x86
Windows ME
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ADT2])

(Reporter)

Description

17 years ago
Trunk build 2002-04-05: WinMe
haven't tried linux or mac yet.

Overview: Expand the Personal Address Book widget and it crashes. The easiest 
way to reproduce this crash is with an empty list but I have also reproduced it 
with a populated list.

Steps to reproduce:
1. New profile
2. Configure Mail
3. Open AB
4. Create an empty list (notice that the expand/collapse widget does not 
display)
5. Close/reopen the AB window
6. Click on the PAB's expand/collapse

Actual Results: Crash
Expected Results: No crash
(Reporter)

Comment 1

17 years ago
Incident 4876300 (and Incident 4876409)

nsTreeContentView::HasNextSibling 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\tree\src\nsTreeContentView.cpp, 
line 406] 
nsTreeBodyFrame::PaintCell 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\tree\src\nsTreeBodyFrame.cpp, 
line 2297] 
nsTreeBodyFrame::PaintRow 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\tree\src\nsTreeBodyFrame.cpp, 
line 2161] 
nsTreeBodyFrame::Paint 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\tree\src\nsTreeBodyFrame.cpp, 
line 1988] 
PresShell::Paint 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5779] 
nsView::Paint [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 280] 
nsViewManager::RenderDisplayListElement 
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1181] 
nsViewManager::RenderViews 
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1130] 
nsViewManager::Refresh [d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, 
line 721] 
nsViewManager::DispatchEvent 
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1721] 
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 83] 
nsWindow::DispatchEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 869] 
nsWindow::DispatchWindowEvent 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 891] 
nsWindow::OnPaint [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, 
line 4509] 
nsWindow::ProcessMessage 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3398] 
nsWindow::WindowProc 
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 1131] 
KERNEL32.DLL + 0x3613 (0xbff63613) 
KERNEL32.DLL + 0x248f7 (0xbff848f7) 
0x00688c16 
0x00058f64 
Keywords: crash
(Reporter)

Comment 2

17 years ago
Marking nsbeta1 since crash should not occur when expanding the Personal Address 
Book widget.
Severity: normal → major
Keywords: nsbeta1

Comment 3

17 years ago
Discussed in Mail News bug mtg with Engineering QA and PjM.  Decided to ADT2 and
plus this bug.
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [ADT2]
Target Milestone: --- → mozilla1.0

Comment 4

17 years ago
works for me with today's build - Ninoschka, is this still happening to you?

Comment 5

16 years ago
Discussed at mail news bug meeting.  Comments seem to imply bug no longer
exists.  Resolving WFM, please reopen if you believe otherwise.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

16 years ago
Branch build 2002-05-22: WinMe, ok.
Trunk build 2002-05-22: WinMe, ok.
Verified Worksforme.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.