Closed Bug 1358750 Opened 2 years ago Closed 2 years ago

Port Bug 1224528 [Provide a mechanism to populate the OneCRL kinto collection with initial records] to SeaMonkey

Categories

(SeaMonkey :: Passwords & Permissions, enhancement)

enhancement
Not set

Tracking

(seamonkey2.50 unaffected, seamonkey2.51 fixed, seamonkey2.52 fixed)

RESOLVED FIXED
seamonkey2.52
Tracking Status
seamonkey2.50 --- unaffected
seamonkey2.51 --- fixed
seamonkey2.52 --- fixed

People

(Reporter: frg, Assigned: frg)

Details

Attachments

(3 files)

+++ This bug was initially created as a clone of Bug #1224528 +++

It would be desirable if the kinto version of the OneCRL Certificate blocklist did not need to fetch initial data from the kinto server.

The blocklist.xml used by the AMO version of OneCRL is shipped with products; we need a similar mechanism which allows initial versions to be read from a user's profile.
Attached image Capture.PNG
Error message shown in a new profile at least. The screenshot is from TB Daily but its the same for SeaMonkey.
[Approval Request Comment]
Regression caused by (bug #): 1224528
User impact if declined: More network traffic during startup. The blocklists will be populated over time.
Testing completed (on m-c, etc.): c-c and c-a
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none
Attachment #8860607 - Flags: review?(iann_bugzilla)
Attachment #8860607 - Flags: approval-comm-beta?
Jorg, I think this patch would fix it for TB but I didn't test it yet.
Attachment #8860613 - Flags: review?(jorgk)
Thanks, somewhat unrelated, this went past recently:
https://hg.mozilla.org/mozilla-central/rev/4266cb39733d
Should we port that?
>> Thanks, somewhat unrelated, this went past recently:

Have it already in my SeaMonkey since Tuesday and seems to work. Was backed out the first time in m-i because of test issues I think. Now that its back should be safe to put it in. SeaMonkey currently doesn't have it enabled see bug 1305902 but this might change and I prefer the SeaMonkey installer to be as close as possible to FF. I will put up a separate bug.
Comment on attachment 8860607 [details] [diff] [review]
1358750-blocklist.patch

LGTM r/a=me
Attachment #8860607 - Flags: review?(iann_bugzilla)
Attachment #8860607 - Flags: review+
Attachment #8860607 - Flags: approval-comm-beta?
Attachment #8860607 - Flags: approval-comm-beta+
Comment on attachment 8860613 [details] [diff] [review]
1358750-blocklist-tb.patch

We'll have it too ;-)
Attachment #8860613 - Flags: review?(jorgk) → review+
You need to log in before you can comment on or make changes to this bug.