We shouldn't hit the symbolication server for non-Windows platforms

REOPENED
Unassigned
(NeedInfo from)

Status

P3
normal
REOPENED
2 years ago
2 months ago

People

(Reporter: kmag, Unassigned, NeedInfo)

Tracking

unspecified
mozilla56
Points:
---

Firefox Tracking Flags

(firefox56 fixed)

Details

(Whiteboard: [PI:July])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Currently, when running with profiling enabled, we try to fetch symbols from the symbolication server after every test cycle. We do this for every platform, even though we only actually try to fetch symbols for Windows.

This needlessly slows things down on other platforms under the best of circumstances. But after a few test runs, I usually seem to wind up getting throttled, and waiting for many minutes after each cycle. At this point, I've wound up manually disabling the symbolication server in symbolicationRequest.py, since there doesn't seem to be a way to configure it.
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1331807
(Reporter)

Comment 2

2 years ago
My current workaround is to just break the symbol server by adding a line to my hosts file:

0.0.0.0 symbolapi.mozilla.org
Whiteboard: [PI:June]
Flags: needinfo?(ionut.goldan)
I'm looking into it now.
Flags: needinfo?(ionut.goldan)
Assignee: nobody → ionut.goldan
:kmag Do you want symbols for the windows platform and that only, in all scenarios, and ignore symbols for linux and macosx? Or are you looking for a platform match? By this second option, I mean that if you test a build on platform X, you should only fetch symbols from that same platform X, not from Y and Z also.
Flags: needinfo?(kmaglione+bmo)
(Reporter)

Comment 5

2 years ago
(In reply to Ionuț Goldan [:igoldan], Performance Sheriffing from comment #4)
> :kmag Do you want symbols for the windows platform and that only, in all
> scenarios, and ignore symbols for linux and macosx?

I'd prefer that we only try to fetch symbols on Windows. We can usually get symbols from nm on other platforms, anyway, and the symbol server won't have symbols for local builds, so I think we're better off avoiding the network overhead and throttling issues.
Flags: needinfo?(kmaglione+bmo)

Comment 7

2 years ago
mozreview-review
Comment on attachment 8882431 [details]
Bug 1358818 - avoid symbolication server for non-Windows platforms

https://reviewboard.mozilla.org/r/153504/#review158722
Attachment #8882431 - Flags: review?(jmaher) → review+
this doesn't pass on try, but it could be a --geckoProfiler issue:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=5df6d23c51b97b2e3e64d0d8026fd20cf38bc2c1

can you prove this works locally?

Also we should make it check for both windows and microsoft:
https://dxr.mozilla.org/mozilla-central/source/testing/talos/talos/utils.py#29
Comment hidden (mozreview-request)
thanks for the update- I guess validating we can get a profile locally would be good prior to landing.
The best thing for this would be to add some basic unittests. I'll work on that.
Comment hidden (mozreview-request)
Whiteboard: [PI:June] → [PI:July]
I validated this locally, by placing logs on the relevant GeckoProfile code. Non-windows platforms aren't hitting the symbols server anymore. Can you merge this?
Flags: needinfo?(jmaher)
Flags: needinfo?(jmaher)

Comment 14

2 years ago
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8c1975262e1a
avoid symbolication server for non-Windows platforms r=jmaher

Comment 15

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/8c1975262e1a
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Depends on: 1493261
This patch was backed out in bug 1493261.

However, in the time since this bug was filed, the symbolication server was rewritten; it should now respond a lot faster and not throttle you, so the bug as filed should hopefully no longer exist.

Kris, can you check whether this issue still happens for you?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
ni?ing :kmag, based on comment 16.
Flags: needinfo?(kmaglione+bmo)
Priority: -- → P3
Assignee: igoldan → nobody
You need to log in before you can comment on or make changes to this bug.