Thunderbird crashes when compacting folder

RESOLVED DUPLICATE of bug 1158578

Status

RESOLVED DUPLICATE of bug 1158578
2 years ago
2 years ago

People

(Reporter: peter.peltonen, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36

Steps to reproduce:

1. Start Thunderbird (52.0.1 64bit on macOS Sierra 10.12.4)
2. Mark some messages deleted on IMAP account 
3. Right click IMAP account and choose "Compact"


Actual results:

Thunderbird crashes almost instantly. I get to send an error report to Apple. Sometimes I also get to send a report to Mozilla, but not always. When I reopen TB the inbox is still uncompacted. 

I have multiple IMAP accounts on different servers (all using Dovecot). It is not account related: compacting on any of these accounts causes the crash. 

This behaviour started after upgrading to TB 52. I do not remember if I had skipped some earlier versions before upgrading. I am on the release channel. 


Expected results:

Deleted messages should be compacted away from the inbox and TB shouldn't crash.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1158578
You need to log in before you can comment on or make changes to this bug.