Closed Bug 1359028 Opened 4 years ago Closed 4 years ago

The red dashed outline Browser Toolbox highlighter is gone

Categories

(DevTools :: Inspector, defect, P1)

defect

Tracking

(firefox-esr52 unaffected)

RESOLVED FIXED
Firefox 55
Tracking Status
firefox-esr52 --- unaffected

People

(Reporter: pbro, Assigned: zer0)

References

Details

(Keywords: regression, Whiteboard: [nosdk])

Attachments

(1 file)

STR:
- open nightly
- open the Browser Toolbox
- click on the element picker icon
- move your mouse over the main browser window to select an element (like a tab)

Expected: there should be a red dashed outline that indicates which element is currently hovered

Actual: the outline is gone, making it hard to select elements and see which one is currently selected/hovered in the Browser Toolbox markup-view.

This seems to be very recent, maybe in the last couple of days. 
Maybe bug 1353005 is the culprit?
Matteo, Julian just confirmed to me on IRC that this was indeed related ot bug 135005. Do you mind taking a look at this regression please?
Blocks: 1353005
Flags: needinfo?(zer0)
Keywords: regression
Assignee: nobody → zer0
Flags: needinfo?(zer0)
The patch of bug 1353005 removed by mistake a leading dot in a css class, and the `encodeURIComponent` calls (so the # in the color definition was considered the hash part in the url).

Also, it appears autoland rejected the last commit from Bug 1353005, so this patch includes those changes as well.
Comment on attachment 8861073 [details]
Bug 1359028 - added encodeURIComponent and fixed css class typo;

https://reviewboard.mozilla.org/r/133056/#review136056

Thanks for fixing this quickly!
Attachment #8861073 - Flags: review?(pbrosset) → review+
Pushed by mferretti@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5046bec1e8ea
added encodeURIComponent and fixed css class typo; r=pbro
https://hg.mozilla.org/mozilla-central/rev/5046bec1e8ea
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Flags: qe-verify-
Priority: -- → P1
Whiteboard: [nosdk]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.