add-on not working in version 52 and above.

RESOLVED INVALID

Status

RESOLVED INVALID
2 years ago
4 months ago

People

(Reporter: sunil.giri, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8860951 [details]
threatscape-plugin-firefox.zip

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36

Steps to reproduce:

Version 53
1) on about:debugging#addons page.
2) loaded my plugin by clicking on Load Temporary Add-on.
3) after installation it's not working.
Error on browser console.
Cannot send function call result: other side closed connection  ExtensionParent.jsm:554

Version 51
1) on about:debugging#addons page.
2) loaded my plugin by clicking on Load Temporary Add-on.
3) after installation it worked as expected.


Actual results:

Add-on not working in version 52 and 53
getting error
Cannot send function call result: other side closed connection  ExtensionParent.jsm:554

Same codebase working in version 51


Expected results:

should work as expected in version 52 and 53 also.

attaching the plugin zip file.
(Reporter)

Comment 1

2 years ago
uncaught exception: unknown (can't convert to string)  (unknown)

on line 
browser.tabs.query({active: true, currentWindow: true}, function(tabs) {}

Updated

2 years ago
Component: Untriaged → Extension Compatibility
Component: Extension Compatibility → WebExtensions: Untriaged
Product: Firefox → Toolkit
Version: 52 Branch → unspecified
(Reporter)

Comment 2

2 years ago
Hi @jorge Villalobos,

Please help me to get what exactly is the issue as i am getting exception

uncaught exception: unknown (can't convert to string)  (unknown)

on line 
browser.tabs.query({active: true, currentWindow: true}, function(tabs) {}.

Updated

2 years ago
Flags: needinfo?(amckay)

Comment 3

2 years ago
To be able to work with this bug, we'd need to know what the problem is. Could you clarify the problem? Also a small reproducible test case (not a 5.37MB extension) would be helpful.

If you are looking for general questions please try the mailing list or IRC channels: https://wiki.mozilla.org/Add-ons#Getting_in_touch
Flags: needinfo?(amckay) → needinfo?(sunil.giri)
(Reporter)

Comment 4

2 years ago
Hi Guys,

Thanks a lot, i got the bug, actually it was because of some popup blown away, and i was trying to access components of it, giving me.

"can't access dead object" Exception, in version 53

but in 51 it was working fine.

It will be helpful, if you guys can help me to understand why it was not the case in version 51.
Flags: needinfo?(sunil.giri)

Comment 5

2 years ago
This bug tracker is track bugs and features going into Firefox, not general add-on support. Sorry, you'll have to get the example down to a reproducible test case and if its a bug in Firefox, open a bug.

In the meantime please try the IRC or mailing lists mentioned in comment 3.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID

Updated

4 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.