Use ShortcutManager to create pinned shortcuts on Android launcher home screen

RESOLVED DUPLICATE of bug 1372926

Status

()

Firefox for Android
Web Apps
RESOLVED DUPLICATE of bug 1372926
6 months ago
4 months ago

People

(Reporter: friedger, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170418123315

Steps to reproduce:

The recommended method to create pinned shortcuts, i.e. icon of website (app manifest) on the home screen of the launcher is requestPinShortcut



Actual results:

Using the currrent method only creates an app shortcut, not the web page


Expected results:
(Reporter)

Comment 1

6 months ago
blocks https://bugzilla.mozilla.org/show_bug.cgi?id=1349309
Blocks: 1349309

Comment 2

4 months ago
Is the same behavior like in Bug 1372926? Or you mean smtg different?
Flags: needinfo?(mail)
(Reporter)

Comment 3

4 months ago
Yes, this is a duplicate then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Flags: needinfo?(mail)
Resolution: --- → DUPLICATE
Duplicate of bug: 1372926
You need to log in before you can comment on or make changes to this bug.