mail crashes when checking for new mail when going offline

VERIFIED WORKSFORME

Status

MailNews Core
Backend
--
critical
VERIFIED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Hans Schleichert, Assigned: Scott MacGregor)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.9+) Gecko/20020308
BuildID:    2002030803

When I go offline and click "download" in reply to the "work offline" dialog,
mail crashes immediately

Reproducible: Always
Steps to Reproduce:
1. Start mozilla mail online.
2. Click the "connection" icon in the lower right corner.
3. A dialog "work offline" pops up and asks you whether to download messages.
Click "download". The "Always ask..." checkbox should be checked (but maybe this
isn't necessary).

Actual Results:  Mozilla mail crashes immediately because of an access violation.

Expected Results:  Mozilla should have checked for mail, then switched to
offline mode.

I've seen this bug since the 0.9.9 milestone build but never before. I am using
a dialup connection and several POP accounts.
(Reporter)

Comment 1

16 years ago
Addition - downloading mail works when I click the "Get Msgs" button on the toolbar.

Comment 2

16 years ago
Reporter, could you install the latest nightly build and try it again?

If you are crashing in Mozilla the best thing you can do to help the developers
fix your bug is to attach a stacktrace. If you're not building yourself you are
not out of luck. Mozilla releases nightly and milestone builds with Full
Circle's Talkback (you can get latest build on:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/) Talkback should catch most
crashes and offer to send in a crash report. Developers can retrieve that crash
report and attach it to your bug report if you provide either the Incident ID
(you can get it by running the talkback program from /components/talkback/).
Thanks for your help in testing Mozilla and reporting bugs.
Severity: major → critical
Keywords: crash

Comment 3

16 years ago
Works for me ! WinXP and build 2002040608.

Reporter's build seems to be a little older ? 8 march ?
(Reporter)

Comment 4

16 years ago
I downloaded the the executable in question on April 6... however, with the
latest build, it seems to be fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 5

16 years ago
marking verified worksforme based on reporter's last comment
Status: RESOLVED → VERIFIED
QA Contact: gayatri → laurel
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.