Last Comment Bug 135913 - Reloading the page doesn't work as intended
: Reloading the page doesn't work as intended
Status: RESOLVED WORKSFORME
:
Product: Core
Classification: Components
Component: Networking: Cache (show other bugs)
: Trunk
: x86 All
: P3 normal (vote)
: mozilla1.3alpha
Assigned To: Nobody; OK to take it and work on it
:
: Patrick McManus [:mcmanus]
Mentors:
http://homepage.eircom.net/~leslie/te...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-06 03:36 PST by Markku Virtanen
Modified: 2015-12-14 17:36 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Test HTML file. (251 bytes, text/plain)
2011-07-22 10:41 PDT, Marco Castelluccio [:marco]
no flags Details

Description Markku Virtanen 2002-04-06 03:36:23 PST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

This modem speed test cannot be repeated by pressing "reload" (with or without
shift-key). With earlier versions of Mozilla this worked properly.

(Though repeating test could be done by pressing back-button.)

Reproducible: Always
Steps to Reproduce:
1. Go to the page http://homepage.eircom.net/~leslie/testpage.html
2. Press "56/ISDN" link
3. When loaded the test picture and speed results try 'reload' the test

Actual Results:  Nothing happened (except some colours changed in the result page).

Expected Results:  The test should have started again.
Comment 1 André Dahlqvist 2002-04-06 13:05:12 PST
You pasted the wrong URL, it should be:

http://homepage.eircom.net/~leslie/testpage.htm
Comment 2 David G King 2002-04-06 17:14:50 PST
This might be a seperate bug, but View-Page Source gives a blank window. (build
20020406). 
Comment 3 John Levon 2002-04-20 08:56:02 PDT
Confirming the problem. Works in ns4.

Page source is occassionally blank :/
Comment 4 Michael Gabriel 2002-07-01 21:57:15 PDT
WFM 2002062808 win2k
Comment 5 Michael Gabriel 2002-08-21 13:39:27 PDT
hmm, confirming 2002082109 trunk win2k
pressing enter in location bar works
hitting reload fails loading the image
Comment 6 Olivier Vit (just a reporter) 2004-04-20 05:27:11 PDT
works for me 
winxp 1.7b 2004041310
Comment 7 philiptdotcom 2007-04-15 21:40:04 PDT
Often (not sure if "always"), RELOAD doesn't work (at all) in FF (2.0.0.3) for me lately; for example, load http://www.hear.org/starr/hiplants/images/family/caprifoliaceae.htm, toggle en-/dis-abling JavaScript; reload; then toggle again; reload.  With JavaScript ENabled, square images should appear in 2nd column of table (bottom part of page); with JavaScript DISabled, just the words "Yahoo images" should appear in that cell.

This is just an EXAMPLE of "reload" not working.  Same occurs even if I use Tools | Clear private data (with "cache" checked) in between.  Have tried both 50 Mb cache (seemingly the default) and ZERO Mb cache, with same results.
Comment 8 Marco Castelluccio [:marco] 2011-07-22 10:28:32 PDT
I can confirm this bug is also for Firefox 7 Aurora.
Reload doesn't work (it starts to load indefinitely), instead pressing enter in the url bar works.
And page source isn't showed, but can be saved to the disk.

Maybe it's due to the fact that the page is entirely written with javascript, after using document.close().
Comment 9 Marco Castelluccio [:marco] 2011-07-22 10:41:05 PDT
Created attachment 547738 [details]
Test HTML file.

I've managed to reproduce the bug: http://abral.altervista.org/firefox/test.htm

And if I directly copy the link from the URL bar: wyciwyg://72/http://abral.altervista.org/firefox/test.htm

So maybe it's related also to the cache.

Note You need to log in before you can comment on or make changes to this bug.