Reloading the page doesn't work as intended

RESOLVED WORKSFORME

Status

()

Core
Networking: Cache
P3
normal
RESOLVED WORKSFORME
15 years ago
2 years ago

People

(Reporter: Markku Virtanen, Unassigned)

Tracking

Trunk
mozilla1.3alpha
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

This modem speed test cannot be repeated by pressing "reload" (with or without
shift-key). With earlier versions of Mozilla this worked properly.

(Though repeating test could be done by pressing back-button.)

Reproducible: Always
Steps to Reproduce:
1. Go to the page http://homepage.eircom.net/~leslie/testpage.html
2. Press "56/ISDN" link
3. When loaded the test picture and speed results try 'reload' the test

Actual Results:  Nothing happened (except some colours changed in the result page).

Expected Results:  The test should have started again.

Comment 1

15 years ago
You pasted the wrong URL, it should be:

http://homepage.eircom.net/~leslie/testpage.htm

Comment 2

15 years ago
This might be a seperate bug, but View-Page Source gives a blank window. (build
20020406). 

Comment 3

15 years ago
Confirming the problem. Works in ns4.

Page source is occassionally blank :/
Keywords: 4xp
OS: Windows XP → All
Summary: Repeating does not work → Reloading the page doesn't work as intended

Comment 4

15 years ago
WFM 2002062808 win2k

Comment 5

15 years ago
hmm, confirming 2002082109 trunk win2k
pressing enter in location bar works
hitting reload fails loading the image
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

15 years ago
Priority: -- → P3
Target Milestone: --- → mozilla1.3alpha
works for me 
winxp 1.7b 2004041310

Comment 7

10 years ago
Often (not sure if "always"), RELOAD doesn't work (at all) in FF (2.0.0.3) for me lately; for example, load http://www.hear.org/starr/hiplants/images/family/caprifoliaceae.htm, toggle en-/dis-abling JavaScript; reload; then toggle again; reload.  With JavaScript ENabled, square images should appear in 2nd column of table (bottom part of page); with JavaScript DISabled, just the words "Yahoo images" should appear in that cell.

This is just an EXAMPLE of "reload" not working.  Same occurs even if I use Tools | Clear private data (with "cache" checked) in between.  Have tried both 50 Mb cache (seemingly the default) and ZERO Mb cache, with same results.
Assignee: gordon → nobody
QA Contact: tever → networking.cache
I can confirm this bug is also for Firefox 7 Aurora.
Reload doesn't work (it starts to load indefinitely), instead pressing enter in the url bar works.
And page source isn't showed, but can be saved to the disk.

Maybe it's due to the fact that the page is entirely written with javascript, after using document.close().
Created attachment 547738 [details]
Test HTML file.

I've managed to reproduce the bug: http://abral.altervista.org/firefox/test.htm

And if I directly copy the link from the URL bar: wyciwyg://72/http://abral.altervista.org/firefox/test.htm

So maybe it's related also to the cache.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.