directory.xul file shows up briefly in URL field on ftp load

VERIFIED FIXED in M14

Status

()

Core
Networking
P3
minor
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Paul MacQuiddy, Assigned: Chris Waterson)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-], URL)

(Reporter)

Description

19 years ago
When you load an ftp directory such as
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/current/ the
directory.xul file that is loaded shows up in the Location bar for a brief time.
It probably shouldn't. Not a huge deal for now though, IMHO.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Reporter)

Comment 1

19 years ago
the file name no longer goes away, it stays in the URL field, 9/24 builds

Comment 2

19 years ago
This seems to be a dupe of Bug 14560 that already has some dup markings in it.

I will let the experts mark the dup option if that is correct.
(Assignee)

Comment 3

19 years ago
*** Bug 14560 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

19 years ago
QA Contact: paulmac → tever
(Assignee)

Updated

19 years ago
Summary: directory.xul file shows up briefly in URL field on ftp load → [DOGFOOD] directory.xul file shows up briefly in URL field on ftp load
(Assignee)

Comment 4

19 years ago
screws up URL bar. marking as dogfood.

Updated

19 years ago
Whiteboard: [PDT-]

Comment 5

19 years ago
Putting on PDT- radar.  Not necessary fix for dogfood.
(Assignee)

Comment 6

19 years ago
*** Bug 18546 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

19 years ago
I'm not seeing this anymore...

Comment 8

19 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.

Updated

19 years ago
Status: RESOLVED → REOPENED
Target Milestone: M12 → M13

Comment 9

19 years ago
It's happening again on build 2000011908 on WinNT. This is clearly a regression.
I'm clicking on the "etc." link off www.mozilla.org to look at the latest
nightly build. However, just typing in an ftp site in the location causes this
to happen.
adding myself as cc: and marking M13 - as it was previously marked as M12.
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
Target Milestone: M13 → M14
(Assignee)

Comment 10

19 years ago
I also notice that the throbber never stops.

Comment 11

19 years ago
throbber not stopping is here http://bugzilla.mozilla.org/show_bug.cgi?id=22322

Updated

19 years ago
Resolution: WORKSFORME → ---

Comment 12

19 years ago
Clearing WORKSFORME resolution due to this bug being set to open.
(Assignee)

Comment 13

19 years ago
*** Bug 24589 has been marked as a duplicate of this bug. ***

Comment 14

19 years ago
xul file url neva eva goes away on m13 builds.
and the directory listing doesn't show up on 02/01/00 win32 builds.

removing pdt- and putting on the beta1 radar
Keywords: beta1
Whiteboard: [PDT-]

Comment 15

19 years ago
using the 02/01/00 build

the directory listing not showing problem appears when I try
ftp://ftp.mozilla.org   

I get a directory file listing when I go to ftp://sweetlou
and I'm able to navigate down through the directory tree
but the display update and scrolling is pretty hurky jerky.

looks like we need some analysis to figure out the conditions
that make this behave funny from build to build and site to site.

tever?

Comment 16

19 years ago
PDT- for b1. WOuld be nice to fix, but we wouldn't hold for it.
Whiteboard: [PDT-]

Comment 17

19 years ago
Putting dogfood in the keyword field.
Keywords: dogfood

Updated

19 years ago
Summary: [DOGFOOD] directory.xul file shows up briefly in URL field on ftp load → directory.xul file shows up briefly in URL field on ftp load
(Reporter)

Comment 18

19 years ago
I don't see this happening anymore. Maybe it could be marked resolved.
(Assignee)

Comment 19

19 years ago
i guess it's fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 20

19 years ago
verified:  NT 2000042009
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.