When viewing local copies of pages saved with "save as" Mozilla crashes

VERIFIED DUPLICATE of bug 134374

Status

()

--
critical
VERIFIED DUPLICATE of bug 134374
17 years ago
17 years ago

People

(Reporter: mozilla, Assigned: dougt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020404
BuildID:    2002040410

Pretty much as stated in the summary. If you save a page using "file/save as"
and then try to view the locally cached results of this, then mozilla will die
with a segmentation fault. I am not sure if this happens on every site, or
whether I was just "lucky" enough to pick the one site that causes mozilla to
crash. I will attach my saved website to this bug shortly so that others can at
least see what I see (I hope :-)


Reproducible: Always
Steps to Reproduce:
1. unpack the attached file onto a "local" disk (ie. /home/user)
2. view the website (ie. file:///home/user/testcase)
3. Click on the link "Moo and Sue's home page.html"


Actual Results:  Mozilla dies

Expected Results:  Mozilla shows the page

Note: If you save these files into your own web area and then look at them with
the http: protocol they look exactly as the original site, so the files are all
"OK" for some definition thereof.
(Reporter)

Comment 1

17 years ago
Created attachment 78024 [details]
The already packed website that cause the problem. (http://www.mooandsue.com/)

This is the testcase that causes the crash for me. It was created by viewing
http://www.mooandsue.com/ and then using "File/save as".

Comment 2

17 years ago
I don't crash with linux 2002040510. I didn't know that "Save As" also saves all
subsequent pages (?), not just the images and scripts.

Comment 3

17 years ago
Happened to me. Build ID: 2002040410, on x86 Linux. Check out Talkback incident
TB4889096W.

If it's WORKSFORME on 0510, then there's no issue. But I'll confirm it anyways.
Best to be cautious.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
worksofme linux trunk 2002040604

i saved the page locally and no crash.

arthur, if you press Select As and select 'Web Page, complete' then it will save
additional data as well. (BUT when saving 'complete' data, the data is saved
from DOM and not source)

*** This bug has been marked as a duplicate of 134374 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.