Open Bug 1359355 Opened 3 years ago Updated 2 years ago

[Form Autofill] Dismiss preview highlight if the filled fields are changed by the website

Categories

(Toolkit :: Form Manager, enhancement, P3)

52 Branch
enhancement

Tracking

()

REOPENED

People

(Reporter: ralin, Unassigned)

References

Details

(Whiteboard: [form autofill])

Right now, we keep the highlight style after filling the profile to show that those fields were auto-filled by browser. The preview highlight should be dismissed at the point the value is being changed programmatically or manually or by reset button. 

Below are some conditions I think of now that need to be handled:
1. inputElement.value = "arbitrary value"
2. user edits the fields
3. user clicks on reset button

Perhaps, we should add some listeners for "change" or "reset" event?
Whiteboard: [form autofill:MVP] → [form autofill:M3]
duplicating this as part 3 commit in bug 1300996 addresses the same issue.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1300996
Whiteboard: [form autofill:M3] → [form autofill]

(In reply to Ray Lin[:ralin] from comment #0)

  1. inputElement.value = "arbitrary value"

I don't think this case was handled

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: [Form Autofill] Dismiss preview highlight if the filled fields is being changed → [Form Autofill] Dismiss preview highlight if the filled fields are changed by the website
See Also: → 1524439
You need to log in before you can comment on or make changes to this bug.