Closed Bug 1359374 Opened 3 years ago Closed Last year

Crash in nsCocoaWindow::SetMenuBar with MOZ_HEADLESS=1

Categories

(Core :: Widget: Cocoa, defect, P5, critical)

Unspecified
macOS
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox55 --- affected

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: crash, Whiteboard: tpi:+)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-0845d757-f234-49a0-9401-8ae8a0170425.
=============================================================

Seen while looking at Mac crash stats on nightly. Comment says:

I just downloaded a fresh copy of Firefox nightly, went to about:config and changed the default remote debugging port from 6000 to 9222, and I started with MOZ_HEADLESS-1.

It printed out *** You are running in headless mode for a moment and crashed.

ni on :bdahl since it looks as if he works in this area.
Flags: needinfo?(bdahl)
Adding :mstange and :spohl as this looks like an OS X widget crash.
Component: General → Widget: Cocoa
Product: Firefox → Core
These crashes started with bug 1338004 landing. Changing the remote debugging port isn't necessary to trigger the crash. Simply running with MOZ_HEADLESS=1 will reproduce the crash.

Mozregression:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5b25d7259b4f9925f132aa4646d51aece2b78b70&tochange=48ad3b64dea66fa8b2183ff2f7921e1c40f19c8a
Blocks: 1338004
Summary: Crash in nsCocoaWindow::SetMenuBar → Crash in nsCocoaWindow::SetMenuBar with MOZ_HEADLESS=1
Headless isn't supported on MacOS yet.
No longer blocks: 1338004
Depends on: 1355147
Flags: needinfo?(bdahl)
Priority: -- → P3
Whiteboard: tpi:+
Priority: P3 → P5
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.