Replace "Releases" with "ProductVersions"



2 years ago
2 years ago


(Reporter: peterbe, Assigned: peterbe)


Firefox Tracking Flags

(Not tracked)




2 years ago
The point of the Releases is to add those first products to bootstrap. 

Today, our cron job ftpscraper populates (via some magic) ultimately product versions. But if start with nothing, and don't have ftpscraper you need to create your first release some how. 

To avoid the topic of whether we care about people who don't do socorro like we do, the simplest solution is to keep the Releases admin feature but refactor all its underlying code to use the ProductVersions API instead. 

At the moment, we have ProductVersions.get and and we
Let's make that ProductVersions.get, and ProductVersions.put ONLY. Then we no longer need the file and its only class. 

Let's keep the UI for now.


2 years ago
Assignee: nobody → peterbe

Comment 1

2 years ago
This is uglier than I thought. is about make a new release. It calls the stored procedure `add_new_release()`, makes an insert into `product_release_channels` and lastly executes `update_product_versions` [0].
The however `add_new_product()` [1].

I thought this was simpler than that. 

What do you know, by heart I guess, about the difference between these two?

Like, in the admin interface, do you have to add the product first before you can add the release?

Can't we just merge these two into one? Who adds a product without adding a release??

Flags: needinfo?(adrian)

Comment 2

2 years ago
We chatted about this and decided it's not worth it.
Last Resolved: 2 years ago
Flags: needinfo?(adrian)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.