Disk Space cache setting doesn't survive restart - browser.cache.disk.smart_size.enabled missing from the panel

RESOLVED FIXED in Thunderbird 55.0

Status

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: grizzly, Assigned: Paenglab)

Tracking

({regression})

52 Branch
Thunderbird 55.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170413192749

Steps to reproduce:

Setting Disk Space to 50mb doesn't stick.


Actual results:

When TB is reopened, Disk Space setting returns to 350mb. Placing "user_pref("browser.cache.disk.capacity", 51200);" into my user.js file has no effect. Checking the actual disk space results in more than 50mb used, so it's not a UI glitch.


Expected results:

Setting Disk Space to 50mb should stick.
I see this also in 53.0b2. Do you see anything in tools > error console?

Steps:
- open options and change cache setting
- close options
- reopen options - the changed value is there
- restart thunderbird

changed value isn't there
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(grizzly)
Keywords: regression
Summary: TB 52.0.1 - Disk Space Setting Not Kept → Disk Space cache setting doesn't survive restart
Oh, it looks like we're missing the "Override automatic cache management" option that FF has.
We need to add browser.cache.disk.smart_size.enabled to the panel.

Richard, could you take this bug, please.
Flags: needinfo?(richard.marti)
Summary: Disk Space cache setting doesn't survive restart → Disk Space cache setting doesn't survive restart - browser.cache.disk.smart_size.enabled missing from the panel
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #1)
> I see this also in 53.0b2. Do you see anything in tools > error console?
> 
> Steps:
> - open options and change cache setting
> - close options
> - reopen options - the changed value is there
> - restart thunderbird
> 
> changed value isn't there

This is exactly what I'm experiencing. I have items in the error console, but I'm at a loss how to interpret what I'm seeing.
Flags: needinfo?(grizzly)
Summary: Disk Space cache setting doesn't survive restart - browser.cache.disk.smart_size.enabled missing from the panel → Disk Space cache setting doesn't survive restart
(In reply to Jorg K (GMT+2) from comment #2)
> Oh, it looks like we're missing the "Override automatic cache management"
> option that FF has.
> We need to add browser.cache.disk.smart_size.enabled to the panel.
> 
> Richard, could you take this bug, please.

Thanks for the tip. Toggling browser.cache.disk.smart_size.enabled to false seems to have alleviated the problem (at least in the UI). I'll need to wait a while to see if the cache size is physically kept to 50mb.
Summary: Disk Space cache setting doesn't survive restart → Disk Space cache setting doesn't survive restart - browser.cache.disk.smart_size.enabled missing from the panel
Something like this?
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Flags: needinfo?(richard.marti)
Attachment #8861579 - Flags: review?(jorgk)
(In reply to Richard Marti (:Paenglab) from comment #5)
> Something like this?
I think so. You copied all the relevant bits from FF and it works!

If used "in-content", the "v" clashes with "View". And maybe you can explain to me why the "a" for "Compact" doesn't work. Of course that's not part of this bug, but just out of interest.
"v" works directly for me and the "View" isn't touched. In In-content you have to use SHIFT additionally to the normal accesskeys. Here also ALT SHIFT v.
Comment on attachment 8861579 [details] [diff] [review]
Bug1359471.patch

Thanks, using <shift> works. I can land this now with another bug I have.
Attachment #8861579 - Flags: review?(jorgk) → review+
Severity: minor → normal
Okay, I don't set c-n.
https://hg.mozilla.org/comm-central/rev/6050971cbdcd387cbe97d8e43c157a119341b221

Due to the string changes I can't backport this to TB 52 ESR, sorry.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 55.0
You need to log in before you can comment on or make changes to this bug.