Closed Bug 1359477 Opened 5 years ago Closed 5 years ago

Crash in libsystem_kernel.dylib@0x19d42 called from audiounit

Categories

(Core :: Audio/Video: cubeb, defect, P1)

53 Branch
Unspecified
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox-esr52 --- fixed
firefox53 + wontfix
firefox54 --- wontfix
firefox55 --- fixed

People

(Reporter: marcia, Assigned: achronop)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file, 1 obsolete file)

This bug was filed from the Socorro interface and is 
report bp-f8c631f6-5e2f-4daf-a8e2-bd3a60170425.
=============================================================

Rising crash that currently sits at top of 53 mac browser crashes: http://bit.ly/2phO0yd. 

Don't see any useful correlations. Some of the comments - we probably need to focus on the ones where people mentioned it is happening specifically since the upgrade to 53 - https://crash-stats.mozilla.com/report/index/b0886b15-9a5a-4d8f-83ed-997560170421 is one example:

*Switched from wired networking (Ethernet) to wireless in the Location menu under the Apple menu 
*Strangely enough, even though "Firefox crashed", it's still running fine in the background and clicking "Quit Firefox" will unblock the main browser window.. 
*reading iNotes email. 
*This is happening on every start of Firefox since I upgraded to Firefox 53. 
*I keep having this error in Mac Sierra even after completely removing Firefox app and reinstalling it again.
Tracking for 53. Randell or Nick, can you help find someone to investigate this crash?
300 crashes in a week isn't a lot, and it looks like this same signature is happening in greater volume in 52.0.2. There are more crashes happening in Thunderbird from the look of it.
Flags: needinfo?(rjesup)
Flags: needinfo?(n.nethercote)
Version: 55 Branch → 53 Branch
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #1)
> Tracking for 53. Randell or Nick, can you help find someone to investigate
> this crash?
> 300 crashes in a week isn't a lot, and it looks like this same signature is
> happening in greater volume in 52.0.2. There are more crashes happening in
> Thunderbird from the look of it.

I think there may be several crashes within this signature, so we might have to ferret out the ones specific to people having trouble when updating to 53. The "unplug your headset and crash" seems to fall under this signature, yet there are a few other bugs on Mac tracking that issue.
I forgot to add in the initial comment that everyone crashing in 53 is running on 10.12.
Crashes are kinda all over the place...

Lots of these in 53 are nsAuthSambaNTLM::SpawnNTLMAuthHelper() (calling _MD_CreateUnixProcess(), calling fork().  Perhaps a lack of resources?  We should clone a bug off for this one; it's common.

There's one in cubeb I see:    assert(r == 0 && "Deadlock");
https://crash-stats.mozilla.com/report/index/a6321f9c-fc20-42ee-99b4-b56e00170425
(469 of around 2500 hits in the last week across all versions for this assert).

Those appear in 52 and newer, including 52esr.  Padenot, Alex?
Rank: 12
Component: General → Audio/Video: cubeb
Flags: needinfo?(rjesup)
Flags: needinfo?(padenot)
Flags: needinfo?(achronop)
Priority: -- → P1
Summary: Crash in libsystem_kernel.dylib@0x19d42 → Crash in libsystem_kernel.dylib@0x19d42 called from audiounit
Flags: needinfo?(n.nethercote)
I'll let alex handle this one.
Flags: needinfo?(padenot)
0x19d42 seem to be assert() in libc, so we really need to distinguish crashes on things that are up the stack. I think it's fixed in cubeb upstream but I'm not too sure, I was away.
I tried to repro with no lack. I keep an eye on and revisit after the latest cubeb import.
Assignee: nobody → achronop
Flags: needinfo?(achronop)
Too late for a fix for 53 and we are a week away from 54 release. There are only a few crashes on release, though we don't know if that's because the issue is fixed by something external or if the people getting the crash just stopped using Firefox. I'll mark this fix-optional for 54.
We've fixed the underlying issue I think. Alex, this was one of the deadlocks on audio unit, do you have fixed all of them ?
Flags: needinfo?(achronop)
My plan is that is fixed with Bug 1366707. It's low traffic so I cannot say for sure. I do not see something similar after 05-20-2017 (https://crash-stats.mozilla.com/report/index/8e93b314-6356-4384-82e5-1c9770170521) in 55. I continue watching that for 10 more days.
This crash is not reproducible any more. I am closing the bug.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(achronop)
Resolution: --- → FIXED
Is this something we should worry about for ESR52 or just let it ride the 55 train?
Depends on: 1366707
Flags: needinfo?(achronop)
Target Milestone: --- → mozilla55
We have a number of that crash in esr52. We could uplift the following individual commit and not everything from Bug 1366707, which is small and safe.

7a4c711 Alex Chronopoulos       audiounit: synchronize destroy stream and reinit (Bug 1361657)
Flags: needinfo?(achronop)
If you don't mind putting together that patch, that would be great :)
Flags: needinfo?(achronop)
[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration:
User impact if declined: Sporadic crash on OSX when plug/unplug external audio device
Fix Landed on Version: 55
Risk to taking this patch (and alternatives if risky): No risk it works in Nightly for sometime without issues
String or UUID changes made by this patch: N/A

See https://wiki.mozilla.org/Release_Management/ESR_Landing_Process for more info.
Flags: needinfo?(achronop)
Attachment #8880456 - Flags: review?(kinetik)
Attachment #8880456 - Flags: approval-mozilla-esr52?
Comment on attachment 8880456 [details] [diff] [review]
Bug 1359477 - Uplift cubeb patch 7a4c711. r?kinetik

Review of attachment 8880456 [details] [diff] [review]:
-----------------------------------------------------------------

Patch application needs to be added to update.sh before landing.
Attachment #8880456 - Flags: review?(kinetik) → review+
For approval request see comment 17.
Attachment #8880456 - Attachment is obsolete: true
Attachment #8880456 - Flags: approval-mozilla-esr52?
Attachment #8880623 - Flags: review?(kinetik)
Attachment #8880623 - Flags: approval-mozilla-esr52?
Attachment #8880623 - Flags: review?(kinetik) → review+
Comment on attachment 8880623 [details] [diff] [review]
Bug 1359477 - Uplift cubeb patch 7a4c711. r?kinetik

Fix a crash. Let's uplift this to ESR52.3.
Attachment #8880623 - Flags: approval-mozilla-esr52? → approval-mozilla-esr52+
You need to log in before you can comment on or make changes to this bug.