WebExtensions ProxyAPI: need ability to specify username/password for proxy servers requiring authentication

RESOLVED WONTFIX

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED WONTFIX
4 months ago
7 days ago

People

(Reporter: ericjung, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug, {meta})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [proxy][outreach][awe:foxyproxy@eric.h.jung] triaged)

(Reporter)

Description

4 months ago
The current WebExtensions ProxyAPI lacks the ability to specify username/password for use with a proxy server. That prevents the use of proxy servers requiring authentication, which is an enormous share of proxy servers in use on the internet.
(Reporter)

Updated

4 months ago
Blocks: 1283639

Updated

4 months ago
Duplicate of this bug: 1319641
(Reporter)

Updated

4 months ago
Depends on: 1359693

Updated

4 months ago
Keywords: meta
Whiteboard: [proxy][triaged]
(Reporter)

Comment 2

3 months ago
We may be able to get auth to work with https://developer.mozilla.org/en-US/Add-ons/WebExtensions/API/webRequest/onAuthRequired. That wouldn't be as clean as providing auth info in the FindProxyForPAC() function, but could be a good workaround for now.

See also bug 1360404 - Accept credentials in proxyInfo object (non-SOCKS)
Depends on: 1360404
Whiteboard: [proxy][triaged] → [proxy][triaged][outreach]

Updated

2 months ago
Whiteboard: [proxy][triaged][outreach] → [proxy][outreach][awe:foxyproxy@eric.h.jung] triaged
(Reporter)

Comment 3

2 months ago
> We may be able to get auth to work with https://developer.mozilla.org/en-US/Add-ons/WebExtensions/API/webRequest/onAuthRequired.
Confirmed this works, and I have an example extension. However, it does *not* work for SOCKS proxy servers. Only HTTP and HTTPS/SSL proxy servers. So this is not a complete solution.
(Reporter)

Comment 4

2 months ago
> Confirmed this works
There is also no way to change the credentials by request since onAuthRequired() appears to do some caching.
(Reporter)

Comment 5

a month ago
Superseded by 1381290
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.